summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristopher Price2024-02-25 22:25:31 -0800
committerChristopher Price2024-02-25 22:25:31 -0800
commitded6cbc174a191fb7c5af24194553ddf068f3336 (patch)
treeb185358e0b84537a816f255fb92b63308da0e075
parent8f0cdc37ca680dbce0aa74f790d35111c9719b1f (diff)
downloadaur-ocaml-sqlite3.tar.gz
fix build thanks to caleb
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD11
2 files changed, 9 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 512c2b362129..bc01d02dc544 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,12 @@
pkgbase = ocaml-sqlite3
pkgdesc = SQLite3 bindings for OCaml
pkgver = 5.1.0
- pkgrel = 1
+ pkgrel = 2
url = https://mmottl.github.io/sqlite3-ocaml/
arch = x86_64
license = MIT
makedepends = dune
+ makedepends = ocaml-findlib
depends = ocaml
depends = ocaml-stdio
depends = sqlite>=3
diff --git a/PKGBUILD b/PKGBUILD
index 6b5c1a9509c5..6935dbfd03b8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,3 +1,5 @@
+# Maintainer: Christopher Price <pricechrispy at gmail dot com>
+# Contributor: Caleb Maclennan <caleb@alerque.com>
# Contributor: Eric Fung <loseurmarbles[AT]gmail[DOT]com>
# Contributor: Dimitris Kiziridis <ragouel at outlook dot com>
# Contributor: Tambet Arak <tambetarak+nospam@gmail.com>
@@ -7,13 +9,13 @@
pkgname=ocaml-sqlite3
pkgver=5.1.0
-pkgrel=1
+pkgrel=2
arch=('x86_64')
license=('MIT')
pkgdesc='SQLite3 bindings for OCaml'
url='https://mmottl.github.io/sqlite3-ocaml/'
depends=('ocaml' 'ocaml-stdio' 'sqlite>=3')
-makedepends=('dune')
+makedepends=('dune' 'ocaml-findlib')
provides=('sqlite3-ocaml')
replaces=('sqlite3-ocaml')
conflicts=('sqlite3-ocaml')
@@ -33,8 +35,9 @@ package() {
"${pkgdir}/usr/share/licenses/${pkgname}" \
"${pkgdir}/$(ocamlfind -printconf destdir)"
- dune install --prefix "${pkgdir}/usr/share" \
- --libdir "${pkgdir}$(ocamlfind printconf destdir)"
+ dune install --destdir "$pkgdir" \
+ --prefix "/usr/share" \
+ --libdir "$(ocamlfind printconf destdir)"
mv "${pkgdir}/usr/share/doc/sqlite3" "${pkgdir}/usr/share/doc/${pkgname}"