summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDimitris Kiziridis2020-05-14 05:04:40 +0300
committerDimitris Kiziridis2020-05-14 05:04:40 +0300
commit664d8c8919dc8d7fa7effdef22f1c5d4b19e102b (patch)
tree0b6a4e9403f29ba904b4fca50a3e1bbbc3ed00c6
parent6a2682429c693fca9cdb375ddf64032b9025d12e (diff)
downloadaur-664d8c8919dc8d7fa7effdef22f1c5d4b19e102b.tar.gz
sanitize pkgbuild
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD8
2 files changed, 7 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4c8509bb1b5f..aeaf9258c239 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -11,8 +11,8 @@ pkgbase = ocaml-sqlite3
depends = ocaml-base
depends = ocaml-stdio
depends = sqlite3
- source = https://github.com/mmottl/sqlite3-ocaml/archive/5.0.1.tar.gz
- md5sums = 313507fdb7595f12cde3b7207420d6a5
+ source = ocaml-sqlite3-5.0.1.tar.gz::https://github.com/mmottl/sqlite3-ocaml/archive/5.0.1.tar.gz
+ sha256sums = f535982dac06801a0ffd0eb7242323ea72c23e093e0397c73b5ac58f6564d57d
pkgname = ocaml-sqlite3
diff --git a/PKGBUILD b/PKGBUILD
index cc383194c83c..51ad0c72321d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
# Contributor: charlesthehawk at yahoo dot com
# Contributor: Serge Zirukin <ftrvxmtrx@gmail.com>
-pkgname=('ocaml-sqlite3')
+pkgname=ocaml-sqlite3
_pkgname=sqlite3-ocaml
pkgver=5.0.1
pkgrel=1
@@ -14,8 +14,8 @@ pkgdesc='SQLite3 bindings for OCaml'
url='https://github.com/mmottl/sqlite3-ocaml'
depends=('ocaml' 'ocaml-base' 'ocaml-stdio' 'sqlite3')
makedepends=('ocaml-findlib' 'dune')
-source=("https://github.com/mmottl/sqlite3-ocaml/archive/${pkgver}.tar.gz")
-md5sums=('313507fdb7595f12cde3b7207420d6a5')
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/mmottl/sqlite3-ocaml/archive/${pkgver}.tar.gz")
+sha256sums=('f535982dac06801a0ffd0eb7242323ea72c23e093e0397c73b5ac58f6564d57d')
build() {
cd "${srcdir}/${_pkgname}-${pkgver}"
@@ -28,4 +28,6 @@ package() {
mkdir -p "${pkgdir}/$(ocamlfind printconf destdir)"
dune install --prefix="${pkgdir}/usr" \
--libdir="${pkgdir}/$(ocamlfind printconf destdir)"
+ install -Dm644 LICENSE.md -t "${pkgdir}/usr/share/licenses/${pkgname}"
+ mv "${pkgdir}/usr/doc" "${pkgdir}/usr/share"
} \ No newline at end of file