summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEric Fung2021-12-20 02:47:24 -0800
committerEric Fung2021-12-20 02:47:24 -0800
commit9b51f0d0e6c63d034f6c08276f7d9a5d83c22ae5 (patch)
tree479c42208d1ff3618a2ca02599293f54fe36ec8d
parent8282131ccddfa2988d3275e13ee7d7386758b29f (diff)
downloadaur-9b51f0d0e6c63d034f6c08276f7d9a5d83c22ae5.tar.gz
Update to release 5.1.0
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD44
2 files changed, 37 insertions, 25 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e27af3f5e08a..512c2b362129 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,20 @@
pkgbase = ocaml-sqlite3
pkgdesc = SQLite3 bindings for OCaml
- pkgver = 5.0.2
+ pkgver = 5.1.0
pkgrel = 1
- url = https://github.com/mmottl/sqlite3-ocaml
+ url = https://mmottl.github.io/sqlite3-ocaml/
arch = x86_64
license = MIT
- makedepends = ocaml-findlib
makedepends = dune
depends = ocaml
- depends = ocaml-base
depends = ocaml-stdio
- depends = sqlite3
- source = ocaml-sqlite3-5.0.2.tar.gz::https://github.com/mmottl/sqlite3-ocaml/archive/5.0.2.tar.gz
- sha256sums = 345811e9f6dc0478e0b5cc82bd75fc2859fab2a96e8fde424c95df23f4267f9c
+ depends = sqlite>=3
+ provides = sqlite3-ocaml
+ conflicts = sqlite3-ocaml
+ replaces = sqlite3-ocaml
+ options = !strip
+ options = staticlibs
+ source = https://github.com/mmottl/sqlite3-ocaml/releases/download/5.1.0/sqlite3-5.1.0.tbz
+ sha256sums = bb0db711691a8dfa24fe29ec4ecb6912444ad90e0f4c447af89831e6d1dffea5
pkgname = ocaml-sqlite3
-
diff --git a/PKGBUILD b/PKGBUILD
index b3aa798de60a..dc0cc47eb71d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,33 +1,43 @@
-# Maintainer: Dimitris Kiziridis <ragouel at outlook dot com>
+# Contributor: Eric Fung <loseurmarbles[AT]gmail[DOT]com>
+# Contributor: Dimitris Kiziridis <ragouel at outlook dot com>
# Contributor: Tambet Arak <tambetarak+nospam@gmail.com>
# Contributor: oliver < a t > first . in-berlin . de
# Contributor: charlesthehawk at yahoo dot com
# Contributor: Serge Zirukin <ftrvxmtrx@gmail.com>
pkgname=ocaml-sqlite3
-_pkgname=sqlite3-ocaml
-pkgver=5.0.2
+pkgver=5.1.0
pkgrel=1
arch=('x86_64')
license=('MIT')
pkgdesc='SQLite3 bindings for OCaml'
-url='https://github.com/mmottl/sqlite3-ocaml'
-depends=('ocaml' 'ocaml-base' 'ocaml-stdio' 'sqlite3')
-makedepends=('ocaml-findlib' 'dune')
-source=("${pkgname}-${pkgver}.tar.gz::https://github.com/mmottl/sqlite3-ocaml/archive/${pkgver}.tar.gz")
-sha256sums=('345811e9f6dc0478e0b5cc82bd75fc2859fab2a96e8fde424c95df23f4267f9c')
+url='https://mmottl.github.io/sqlite3-ocaml/'
+depends=('ocaml' 'ocaml-stdio' 'sqlite>=3')
+makedepends=('dune')
+provides=('sqlite3-ocaml')
+replaces=('sqlite3-ocaml')
+conflicts=('sqlite3-ocaml')
+options=('!strip' 'staticlibs')
+source=("https://github.com/mmottl/sqlite3-ocaml/releases/download/${pkgver}/sqlite3-${pkgver}.tbz")
+sha256sums=('bb0db711691a8dfa24fe29ec4ecb6912444ad90e0f4c447af89831e6d1dffea5')
build() {
- cd "${srcdir}/${_pkgname}-${pkgver}"
- dune build @install
+ cd "${srcdir}/sqlite3-${pkver}"
+ dune build @install
}
package() {
- cd "${srcdir}/${_pkgname}-${pkgver}"
- mkdir -p "${pkgdir}/usr"
- mkdir -p "${pkgdir}/$(ocamlfind printconf destdir)"
- dune install --prefix="${pkgdir}/usr" \
- --libdir="${pkgdir}/$(ocamlfind printconf destdir)"
- install -Dm644 LICENSE.md -t "${pkgdir}/usr/share/licenses/${pkgname}"
- mv "${pkgdir}/usr/doc" "${pkgdir}/usr/share"
+ cd "${srcdir}/sqlite3-${pkver}"
+
+ install -d "${pkgdir}/usr/share/doc" \
+ "${pkgdir}/usr/share/licenses/${pkgname}" \
+ "${pkgdir}/$(ocamlfind -printconf destdir)"
+
+ dune install --prefix "${pkgdir}/usr/share" \
+ --libdir "${pkgdir}$(ocamlfind printconf destdir)"
+
+ mv "${pkgdir}/usr/share/doc/sqlite3" "${pkgdir}/usr/share/doc/${pkgname}"
+
+ mv "${pkgdir}/usr/share/doc/${pkgname}/LICENSE.md" \
+ "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE.md"
}