summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorOliver Bandel2017-07-13 03:58:15 +0200
committerOliver Bandel2017-07-13 03:58:15 +0200
commitbf2e14299702d66a40dae564019cabb89735d3db (patch)
tree7cfa420f761398d7014b2bfe54a6687a7df79d13
parentf1f276b78ebea0e37bc3fc569dbe512139e2af2f (diff)
downloadaur-bf2e14299702d66a40dae564019cabb89735d3db.tar.gz
ocaml-sqlite3 rel. 4.1.3, and destination of documentation corrected.
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD7
2 files changed, 7 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2f3276a5896f..4b4569998ceb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = ocaml-sqlite3
pkgdesc = SQLite3 bindings for OCaml
- pkgver = 4.1.2
+ pkgver = 4.1.3
pkgrel = 1
url = https://github.com/mmottl/sqlite3-ocaml
arch = i686
@@ -12,8 +12,8 @@ pkgbase = ocaml-sqlite3
makedepends = ocamlbuild
options = !makeflags
options = staticlibs
- source = https://github.com/mmottl/sqlite3-ocaml/releases/download/v4.1.2/sqlite3-ocaml-4.1.2.tar.gz
- md5sums = a824c24d1011388eaf15f752bd02494e
+ source = https://github.com/mmottl/sqlite3-ocaml/releases/download/v4.1.3/sqlite3-ocaml-4.1.3.tar.gz
+ md5sums = 1b7c29a831fb517dfa0df399eaea2ceb
pkgname = ocaml-sqlite3
diff --git a/PKGBUILD b/PKGBUILD
index 4d589d203be6..830357248a9b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=ocaml-sqlite3
_pkgname=sqlite3-ocaml
-pkgver=4.1.2
+pkgver=4.1.3
pkgrel=1
pkgdesc="SQLite3 bindings for OCaml"
arch=('i686' 'x86_64')
@@ -12,7 +12,7 @@ url="https://github.com/mmottl/sqlite3-ocaml"
license=('MIT')
makedepends=('ocaml' 'ocaml-findlib' 'sqlite3' 'ocamlbuild')
source=("https://github.com/mmottl/sqlite3-ocaml/releases/download/v$pkgver/sqlite3-ocaml-$pkgver.tar.gz")
-md5sums=('a824c24d1011388eaf15f752bd02494e')
+md5sums=('1b7c29a831fb517dfa0df399eaea2ceb')
options=('!makeflags' 'staticlibs')
_pkgdir="$_pkgname-$pkgver"
@@ -20,7 +20,7 @@ _pkgdir="$_pkgname-$pkgver"
build () {
cd "${srcdir}/${_pkgdir}"
- ./configure --disable-debug --prefix "$pkgdir/usr" --destdir "$pkgdir"
+ ./configure --disable-debug --prefix "$pkgdir/usr" --destdir "$pkgdir" --docdir "/usr/share/${pkgname}"
make all
}
@@ -28,6 +28,7 @@ package() {
cd "${srcdir}/${_pkgdir}"
export OCAMLFIND_DESTDIR="$pkgdir$(ocamlfind printconf destdir)"
+ echo $OCAMLFIND_DESTDIR
mkdir -p "${OCAMLFIND_DESTDIR}/stublibs"
make install
install -D -m644 COPYING.txt "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"