summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGianluca Boiano2018-10-11 14:03:13 +0200
committerGianluca Boiano2018-10-11 14:03:13 +0200
commit58b9673442cae91dcb99a663e675a4a10c1d898e (patch)
tree7b2e8da399e87c7ec4df348f49163e70b22918f8
parentff42ad4dfb7bbbc621168b741d067d636e6e67f9 (diff)
downloadaur-58b9673442cae91dcb99a663e675a4a10c1d898e.tar.gz
ocaml-ssl: rework install command
-rw-r--r--PKGBUILD22
1 files changed, 11 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7cd00ca1cf50..434b0a3a0a5b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -15,22 +15,22 @@ source=("https://github.com/savonet/ocaml-ssl/archive/v$pkgver.tar.gz")
options=(!libtool !strip zipman !makeflags staticlibs)
build() {
- cd $pkgname-$pkgver
- make
+ cd $pkgname-$pkgver
+ make
}
package() {
- cd ${pkgname}-${pkgver}
+ cd ${pkgname}-${pkgver}
- # Initialize OPAM, this should be removed once opam is “removed” from dune
- export OPAMROOT="${srcdir}"/opam
- opam init -n
+ # Initialize OPAM, this should be removed once opam is “removed” from dune
+ export OPAMROOT="${srcdir}"/opam
+ opam init -n
- # Work around the install command
- make OCAMLFIND_DESTDIR="${pkgdir}$(ocamlfind printconf destdir)" install
- # Install LICENSE
- mkdir -p $pkgdir/usr/share/licenses/$pkgname/
- awk 'BEGIN{P=0} /License/ {P = 1;} {if (P) print}' README.md > $pkgdir/usr/share/licenses/$pkgname/license
+ # Work around the install command
+ OCAMLFIND_DESTDIR="${pkgdir}$(ocamlfind printconf destdir)" jbuilder install
+ # Install LICENSE
+ mkdir -p $pkgdir/usr/share/licenses/$pkgname/
+ awk 'BEGIN{P=0} /License/ {P = 1;} {if (P) print}' README.md > $pkgdir/usr/share/licenses/$pkgname/license
}
md5sums=('500b0bb7af4a736255ce706cc8e26762')