summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMort Yao2018-04-16 01:51:38 +0200
committerMort Yao2018-04-16 01:51:38 +0200
commit298fbf12eb3bc555d62496613469417dcedba1fc (patch)
tree1968845181ad0120eec44da8d73eb812773d3848
parente6943b184bcda5fdfc2c86b7958c1a1d2ae6df9d (diff)
downloadaur-298fbf12eb3bc555d62496613469417dcedba1fc.tar.gz
ocaml-stdint-git 20180226-1
-rw-r--r--.SRCINFO9
-rwxr-xr-x.gitignore2
-rw-r--r--PKGBUILD17
3 files changed, 11 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a7551c747f22..edd562aa6df9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,14 @@
# Generated by mksrcinfo v8
-# Tue Oct 24 11:38:07 UTC 2017
+# Sun Apr 15 23:51:15 UTC 2018
pkgbase = ocaml-stdint-git
pkgdesc = Various signed and unsigned integers for OCaml
- pkgver = 20171013
- pkgrel = 2
+ pkgver = 20180226
+ pkgrel = 1
url = https://github.com/andrenth/ocaml-stdint
arch = i686
arch = x86_64
license = MIT
- makedepends = ocamlbuild
- makedepends = ocaml-findlib
+ makedepends = dune
provides = ocaml-stdint
source = ocaml-stdint-git::git://github.com/andrenth/ocaml-stdint.git
md5sums = SKIP
diff --git a/.gitignore b/.gitignore
index a6289c1c9dbb..11046d3c70fe 100755
--- a/.gitignore
+++ b/.gitignore
@@ -1,6 +1,6 @@
/pkg
/src
-*-git/
+*.sig
*.bz2
*.gz
*.tar
diff --git a/PKGBUILD b/PKGBUILD
index b5222751c9ae..476329615889 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,14 @@
# Maintainer: Mort Yao <soi@mort.ninja>
pkgname=ocaml-stdint-git
-pkgver=20171013
-pkgrel=2
+pkgver=20180226
+pkgrel=1
pkgdesc="Various signed and unsigned integers for OCaml"
arch=('i686' 'x86_64')
url='https://github.com/andrenth/ocaml-stdint'
license=('MIT')
provides=('ocaml-stdint')
-makedepends=('ocamlbuild' 'ocaml-findlib')
+makedepends=('dune')
source=("${pkgname}::git://github.com/andrenth/ocaml-stdint.git")
md5sums=('SKIP')
@@ -20,18 +20,13 @@ pkgver() {
build() {
cd "$pkgname"
- export OCAMLFIND_DESTDIR="${pkgdir}$(ocamlfind printconf destdir)"
-
- ocaml setup.ml -configure --destdir "${pkgdir}"
- make all
+ jbuilder build -p stdint
}
package() {
cd "$pkgname"
- mkdir -p "${OCAMLFIND_DESTDIR}"
+ mkdir -p "${pkgdir}"/usr/lib/ocaml/
- export OCAMLFIND_LDCONF=FOOBAR
- ocaml setup.ml -install --destdir "$pkgdir"
- rm -r "$pkgdir/usr/local"
+ jbuilder install -p stdint --libdir="${pkgdir}"/usr/lib/ocaml/
}