summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorcrave2020-05-29 18:03:31 +0200
committercrave2020-05-29 18:03:31 +0200
commitea8c7a380e3c21bd699bce096712ecc49dd6347f (patch)
tree6a00cd2f204ed35c0250774fb4bf62750e30861a
parent886b4362e0909b164b22c903c4e53c76a1e4e494 (diff)
downloadaur-ea8c7a380e3c21bd699bce096712ecc49dd6347f.tar.gz
Use dune command since jbuilder seems to have been removed
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD8
2 files changed, 4 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7b537ec79c36..e78eb3d84afe 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,3 @@
-# Generated by mksrcinfo v8
-# Sat Oct 19 21:45:28 UTC 2019
pkgbase = ocaml-stdint-git
pkgdesc = Various signed and unsigned integers for OCaml
pkgver = 20180606
diff --git a/PKGBUILD b/PKGBUILD
index 2f6322d4cc51..aea6f0041625 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Mort Yao <soi@mort.ninja>
pkgname=ocaml-stdint-git
-pkgver=20180606
-pkgrel=2
+pkgver=20200208
+pkgrel=3
pkgdesc="Various signed and unsigned integers for OCaml"
arch=('i686' 'x86_64')
url='https://github.com/andrenth/ocaml-stdint'
@@ -20,7 +20,7 @@ pkgver() {
build() {
cd "$pkgname"
- jbuilder build -p stdint
+ dune build -p stdint
}
package() {
@@ -28,5 +28,5 @@ package() {
mkdir -p "${pkgdir}"/usr/lib/ocaml/
- jbuilder install -p stdint --libdir="${pkgdir}"/usr/lib/ocaml/ --prefix="${pkgdir}"
+ dune install -p stdint --libdir="${pkgdir}"/usr/lib/ocaml/ --prefix="${pkgdir}"
}