summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJakob Gahde2018-06-27 21:59:31 +0200
committerJakob Gahde2018-06-27 21:59:31 +0200
commit54ef5dd57f22796aa422bae8e31f6a0964762a5b (patch)
tree192feef43dea60b023f6ed06d842d23af7c0061c
downloadaur-54ef5dd57f22796aa422bae8e31f6a0964762a5b.tar.gz
ocaml-stdio 0.11.0-1: New package
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD29
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..da936b9d8049
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+# Generated by mksrcinfo v8
+# Wed Jun 27 19:59:15 UTC 2018
+pkgbase = ocaml-stdio
+ pkgdesc = Standard IO library for OCaml
+ pkgver = 0.11.0
+ pkgrel = 1
+ url = https://github.com/janestreet/stdio
+ arch = x86_64
+ license = Apache
+ makedepends = dune
+ depends = ocaml
+ depends = ocaml-base
+ options = !strip
+ source = https://ocaml.janestreet.com/ocaml-core/v0.11/files/stdio-v0.11.0.tar.gz
+ md5sums = 2db42ee38c91b3ff7126c2634c407b99
+
+pkgname = ocaml-stdio
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..65ded5e36e58
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Jakob Gahde <j5lx@fmail.co.uk>
+
+pkgname=ocaml-stdio
+pkgver=0.11.0
+pkgrel=1
+pkgdesc="Standard IO library for OCaml"
+arch=('x86_64')
+url='https://github.com/janestreet/stdio'
+license=('Apache')
+depends=('ocaml' 'ocaml-base')
+makedepends=('dune')
+options=('!strip')
+source=("https://ocaml.janestreet.com/ocaml-core/v$(echo ${pkgver} | grep -Po "^[0-9]+\.[0-9]+")/files/stdio-v${pkgver}.tar.gz")
+md5sums=('2db42ee38c91b3ff7126c2634c407b99')
+
+build() {
+ cd "${srcdir}/stdio-v${pkgver}"
+
+ jbuilder build
+}
+
+
+package() {
+ cd "${srcdir}/stdio-v${pkgver}"
+
+ mkdir -p "${pkgdir}$(ocamlfind printconf destdir)" "${pkgdir}/usr/share"
+ jbuilder install --prefix "${pkgdir}/usr" --libdir "${pkgdir}$(ocamlfind printconf destdir)"
+ mv "${pkgdir}/usr/doc" "${pkgdir}/usr/share/"
+}