summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJakob Gahde2019-05-14 14:09:38 +0200
committerJakob Gahde2019-05-14 14:09:38 +0200
commitfd391cc85b4cf4cc170f9f8d68dd4076ac7433fa (patch)
tree7df114efb15556f3e62d605ef176133896939fb6
parent54ef5dd57f22796aa422bae8e31f6a0964762a5b (diff)
downloadaur-fd391cc85b4cf4cc170f9f8d68dd4076ac7433fa.tar.gz
ocaml-stdio 0.12.0-1: New version
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD11
2 files changed, 10 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index da936b9d8049..6347ace90170 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,16 @@
-# Generated by mksrcinfo v8
-# Wed Jun 27 19:59:15 UTC 2018
pkgbase = ocaml-stdio
pkgdesc = Standard IO library for OCaml
- pkgver = 0.11.0
+ pkgver = 0.12.0
pkgrel = 1
url = https://github.com/janestreet/stdio
arch = x86_64
- license = Apache
+ license = MIT
makedepends = dune
depends = ocaml
depends = ocaml-base
options = !strip
- source = https://ocaml.janestreet.com/ocaml-core/v0.11/files/stdio-v0.11.0.tar.gz
- md5sums = 2db42ee38c91b3ff7126c2634c407b99
+ source = https://ocaml.janestreet.com/ocaml-core/v0.12/files/stdio-v0.12.0.tar.gz
+ sha512sums = 53a8cef84964a2c8c47d5f0572897079cbc5c4983a923f069c6d0ca4558d1c87662eb13b630501815bc2448772312b93735c70813638a786f5213a09b63e03e8
pkgname = ocaml-stdio
diff --git a/PKGBUILD b/PKGBUILD
index 65ded5e36e58..67d65bf10bfc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,22 @@
# Maintainer: Jakob Gahde <j5lx@fmail.co.uk>
pkgname=ocaml-stdio
-pkgver=0.11.0
+pkgver=0.12.0
pkgrel=1
pkgdesc="Standard IO library for OCaml"
arch=('x86_64')
url='https://github.com/janestreet/stdio'
-license=('Apache')
+license=('MIT')
depends=('ocaml' 'ocaml-base')
makedepends=('dune')
options=('!strip')
source=("https://ocaml.janestreet.com/ocaml-core/v$(echo ${pkgver} | grep -Po "^[0-9]+\.[0-9]+")/files/stdio-v${pkgver}.tar.gz")
-md5sums=('2db42ee38c91b3ff7126c2634c407b99')
+sha512sums=('53a8cef84964a2c8c47d5f0572897079cbc5c4983a923f069c6d0ca4558d1c87662eb13b630501815bc2448772312b93735c70813638a786f5213a09b63e03e8')
build() {
cd "${srcdir}/stdio-v${pkgver}"
- jbuilder build
+ dune build
}
@@ -24,6 +24,7 @@ package() {
cd "${srcdir}/stdio-v${pkgver}"
mkdir -p "${pkgdir}$(ocamlfind printconf destdir)" "${pkgdir}/usr/share"
- jbuilder install --prefix "${pkgdir}/usr" --libdir "${pkgdir}$(ocamlfind printconf destdir)"
+ dune install --prefix "${pkgdir}/usr" --libdir "${pkgdir}$(ocamlfind printconf destdir)"
mv "${pkgdir}/usr/doc" "${pkgdir}/usr/share/"
+ install -Dm644 "LICENSE.md" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE.md"
}