summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJakob Gahde2019-09-10 14:13:12 +0200
committerJakob Gahde2019-09-10 14:13:12 +0200
commitab124544ac73902f608b10e2a2bc60a054a8681d (patch)
treec143da986c091bbe6cb45000167df547c6085930
parent89eb403ac04232fe5e9ad25ef24cd6921b73066f (diff)
downloadaur-ab124544ac73902f608b10e2a2bc60a054a8681d.tar.gz
ocaml-taglib 0.3.6-1: Update to new version
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD7
2 files changed, 8 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 081c880ff3d9..3329dc1fe471 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,17 @@
pkgbase = ocaml-taglib
pkgdesc = OCaml bindings to taglib
- pkgver = 0.3.5
+ pkgver = 0.3.6
pkgrel = 1
url = https://github.com/savonet/ocaml-taglib
arch = i686
arch = x86_64
- license = LGPL2.1
+ license = custom:LGPL2.1 with linking exception
makedepends = ocaml-findlib
depends = ocaml
depends = taglib
options = !strip
- source = https://github.com/savonet/ocaml-taglib/releases/download/0.3.5/ocaml-taglib-0.3.5.tar.gz
- sha512sums = d9059445acea347261666efa8808fa8c8794aacaec042a103336acf803472a2838686f3e8422975b0f80e8ea9f0faeaa763fe38b9799ff6067b23caa2c6e5f75
+ source = https://github.com/savonet/ocaml-taglib/releases/download/0.3.6/ocaml-taglib-0.3.6.tar.gz
+ sha512sums = b5744b57beb63761cd5ad1a6d9824e1d3e5da2e94649544217264441a9e561f722b31359df02457465eacf168ff162e5bf524df1c239a98d1277466aa887518a
pkgname = ocaml-taglib
diff --git a/PKGBUILD b/PKGBUILD
index 10bdc0a9dd1c..3ce781aab36e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,17 @@
# Maintainer: Jakob Gahde <j5lx@fmail.co.uk>
pkgname=ocaml-taglib
-pkgver=0.3.5
+pkgver=0.3.6
pkgrel=1
pkgdesc="OCaml bindings to taglib"
arch=('i686' 'x86_64')
url="https://github.com/savonet/ocaml-taglib"
-license=('LGPL2.1')
+license=('custom:LGPL2.1 with linking exception')
depends=('ocaml' 'taglib')
makedepends=('ocaml-findlib')
options=('!strip')
source=("https://github.com/savonet/ocaml-taglib/releases/download/${pkgver}/${pkgname}-${pkgver}.tar.gz")
-sha512sums=('d9059445acea347261666efa8808fa8c8794aacaec042a103336acf803472a2838686f3e8422975b0f80e8ea9f0faeaa763fe38b9799ff6067b23caa2c6e5f75')
+sha512sums=('b5744b57beb63761cd5ad1a6d9824e1d3e5da2e94649544217264441a9e561f722b31359df02457465eacf168ff162e5bf524df1c239a98d1277466aa887518a')
build() {
cd "${srcdir}/${pkgname}-${pkgver}"
@@ -26,4 +26,5 @@ package() {
export OCAMLFIND_DESTDIR="${pkgdir}$(ocamlfind printconf destdir)"
mkdir -p "${OCAMLFIND_DESTDIR}/stublibs"
make install
+ install -Dm644 "COPYING" "${pkgdir}/usr/share/licenses/${pkgname}/COPYING"
}