summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Peukert2023-08-11 12:51:45 +0200
committerDaniel Peukert2023-08-11 12:51:45 +0200
commit28cefc77f67ab33c6f54214565f135ab406c2dca (patch)
tree8cb68757a23f7d2c92beea4ca109163bb3704cf0
parent6ba129fd2af8598befb884bbcb25fa9289ccdaa5 (diff)
downloadaur-28cefc77f67ab33c6f54214565f135ab406c2dca.tar.gz
Add ocaml-async_unix and ocaml-textutils
-rw-r--r--.SRCINFO29
-rw-r--r--.editorconfig8
-rw-r--r--.gitignore14
-rw-r--r--PKGBUILD48
4 files changed, 63 insertions, 36 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4564ac032dab..b1d5ee96742c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,23 +1,22 @@
pkgbase = ocaml-textutils
- pkgdesc = Text output utilities
- pkgver = 0.15.0
+ pkgdesc = Text output utilities for OCaml
+ pkgver = 0.16.0
pkgrel = 1
epoch = 1
url = https://github.com/janestreet/textutils
- arch = i686
arch = x86_64
- license = Apache
- makedepends = dune
- depends = ocaml
- depends = ocaml-core
- depends = ocaml-core_unix
- depends = ocaml-ppx_jane
- depends = ocaml-textutils_kernel
- depends = ocaml-migrate-parsetree
- depends = ocaml-ppxlib
- depends = ocaml-uutf
+ arch = aarch64
+ license = MIT
+ makedepends = dune>=2.0.0
+ depends = ocaml>=4.14.0
+ depends = ocaml-core>=0.16.0
+ depends = ocaml-core_kernel>=0.16.0
+ depends = ocaml-core_unix>=0.16.0
+ depends = ocaml-ppx_jane>=0.16.0
+ depends = ocaml-textutils_kernel>=0.16.0
+ depends = ocaml-uutf>=1.0.2
options = !strip
- source = https://ocaml.janestreet.com/ocaml-core/v0.15/files/textutils-v0.15.0.tar.gz
- sha256sums = c0368fb6ad18727cd69fbfb20dd734fb7f7189707107d1f88d8de15837dc22df
+ source = ocaml-textutils-0.16.0.tar.gz::https://github.com/janestreet/textutils/archive/v0.16.0.tar.gz
+ sha512sums = 860448856cf99388a7c297271c59450d3ebef38fcc0826986f0add442cd633528f4e2b6a4babee567c250716e3fa9535c024550e58d0a082f6677a6378d99760
pkgname = ocaml-textutils
diff --git a/.editorconfig b/.editorconfig
new file mode 100644
index 000000000000..a467ee9a97a6
--- /dev/null
+++ b/.editorconfig
@@ -0,0 +1,8 @@
+root = true
+
+[*]
+charset = utf-8
+end_of_line = lf
+insert_final_newline = true
+indent_style = tab
+tab_width = 4
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..82b3c183d5d4
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,14 @@
+# from https://github.com/github/gitignore/blob/master/ArchLinuxPackages.gitignore
+*.tar
+*.tar.*
+*.rpm
+*.jar
+*.exe
+*.msi
+*.zip
+*.tgz
+*.log
+*.log.*
+*.sig
+
+*/
diff --git a/PKGBUILD b/PKGBUILD
index 8c68ef167dac..6abe0578ad80 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,31 +1,37 @@
-# Maintainer: Michał Wojdyła < micwoj9292 at gmail dot com >
+# Maintainer: Daniel Peukert <daniel@peukert.cc>
+# Contributor: Michał Wojdyła < micwoj9292 at gmail dot com >
# Contributor: Felix Golatofski <contact@xdfr.de>
# Contributor: Jakob Gahde <j5lx@fmail.co.uk>
-
-pkgname=ocaml-textutils
-pkgver=0.15.0
-pkgrel=1
-epoch=1
-pkgdesc="Text output utilities"
-arch=('i686' 'x86_64')
-url="https://github.com/janestreet/textutils"
-license=('Apache')
-depends=('ocaml' 'ocaml-core' 'ocaml-core_unix' 'ocaml-ppx_jane' 'ocaml-textutils_kernel' 'ocaml-migrate-parsetree' 'ocaml-ppxlib' 'ocaml-uutf')
-makedepends=('dune')
+_projectname='textutils'
+pkgname="ocaml-$_projectname"
+pkgver='0.16.0'
+pkgrel='1'
+epoch='1'
+pkgdesc='Text output utilities for OCaml'
+arch=('x86_64' 'aarch64')
+url="https://github.com/janestreet/$_projectname"
+license=('MIT')
+depends=('ocaml>=4.14.0' 'ocaml-core>=0.16.0' 'ocaml-core_kernel>=0.16.0' 'ocaml-core_unix>=0.16.0' 'ocaml-ppx_jane>=0.16.0' 'ocaml-textutils_kernel>=0.16.0' 'ocaml-uutf>=1.0.2')
+makedepends=('dune>=2.0.0')
options=('!strip')
-source=("https://ocaml.janestreet.com/ocaml-core/v$(echo ${pkgver} | grep -Po "^[0-9]+\.[0-9]+")/files/textutils-v${pkgver}.tar.gz")
-sha256sums=('c0368fb6ad18727cd69fbfb20dd734fb7f7189707107d1f88d8de15837dc22df')
+source=("$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz")
+sha512sums=('860448856cf99388a7c297271c59450d3ebef38fcc0826986f0add442cd633528f4e2b6a4babee567c250716e3fa9535c024550e58d0a082f6677a6378d99760')
-build() {
- cd "${srcdir}/textutils-v${pkgver}"
+_sourcedirectory="$_projectname-$pkgver"
- dune build
+build() {
+ cd "$srcdir/$_sourcedirectory/"
+ dune build --release --verbose
}
package() {
- cd "${srcdir}/textutils-v${pkgver}"
+ cd "$srcdir/$_sourcedirectory/"
+ DESTDIR="$pkgdir" dune install --prefix '/usr' --libdir '/usr/lib/ocaml' --docdir '/usr/share/doc' --mandir '/usr/share/man' --release --verbose
+
+ for _folder in "$pkgdir/usr/share/doc/"*; do
+ mv "$_folder" "$pkgdir/usr/share/doc/ocaml-$(basename "$_folder")"
+ done
- install -dm755 "${pkgdir}$(ocamlfind -printconf destdir)" "${pkgdir}/usr/share/"
- dune install --prefix "${pkgdir}/usr" --libdir "${pkgdir}$(ocamlfind -printconf destdir)"
- mv "${pkgdir}/usr/doc" "${pkgdir}/usr/share/"
+ install -dm755 "$pkgdir/usr/share/licenses/$pkgname"
+ ln -sf "/usr/share/doc/$pkgname/LICENSE.md" "$pkgdir/usr/share/licenses/$pkgname/LICENSE.md"
}