summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichał Wojdyła2022-10-03 23:11:19 +0200
committerMichał Wojdyła2022-10-03 23:11:19 +0200
commit6ba129fd2af8598befb884bbcb25fa9289ccdaa5 (patch)
tree77e4850e2c2b527930c63af3c7a6999b9bf26691
parent5373e41bacf37a539c0f236a6137a708ac78ca26 (diff)
downloadaur-6ba129fd2af8598befb884bbcb25fa9289ccdaa5.tar.gz
update to 0.15.0
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD13
2 files changed, 12 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9c4c6f81c9f6..4564ac032dab 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = ocaml-textutils
pkgdesc = Text output utilities
- pkgver = 0.14.0
+ pkgver = 0.15.0
pkgrel = 1
epoch = 1
url = https://github.com/janestreet/textutils
@@ -10,13 +10,14 @@ pkgbase = ocaml-textutils
makedepends = dune
depends = ocaml
depends = ocaml-core
+ depends = ocaml-core_unix
depends = ocaml-ppx_jane
depends = ocaml-textutils_kernel
depends = ocaml-migrate-parsetree
depends = ocaml-ppxlib
+ depends = ocaml-uutf
options = !strip
- source = https://ocaml.janestreet.com/ocaml-core/v0.14/files/textutils-v0.14.0.tar.gz
- sha256sums = 14a2f8393159fcc43bfac82d0100364dc874fee94447aced80ec8ae99e2949eb
+ source = https://ocaml.janestreet.com/ocaml-core/v0.15/files/textutils-v0.15.0.tar.gz
+ sha256sums = c0368fb6ad18727cd69fbfb20dd734fb7f7189707107d1f88d8de15837dc22df
pkgname = ocaml-textutils
-
diff --git a/PKGBUILD b/PKGBUILD
index 1a28f5e46805..8c68ef167dac 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,30 +1,31 @@
-# Maintainer: Felix Golatofski <contact@xdfr.de>
+# Maintainer: Michał Wojdyła < micwoj9292 at gmail dot com >
+# Contributor: Felix Golatofski <contact@xdfr.de>
# Contributor: Jakob Gahde <j5lx@fmail.co.uk>
pkgname=ocaml-textutils
-pkgver=0.14.0
+pkgver=0.15.0
pkgrel=1
epoch=1
pkgdesc="Text output utilities"
arch=('i686' 'x86_64')
url="https://github.com/janestreet/textutils"
license=('Apache')
-depends=('ocaml' 'ocaml-core' 'ocaml-ppx_jane' 'ocaml-textutils_kernel' 'ocaml-migrate-parsetree' 'ocaml-ppxlib')
+depends=('ocaml' 'ocaml-core' 'ocaml-core_unix' 'ocaml-ppx_jane' 'ocaml-textutils_kernel' 'ocaml-migrate-parsetree' 'ocaml-ppxlib' 'ocaml-uutf')
makedepends=('dune')
options=('!strip')
source=("https://ocaml.janestreet.com/ocaml-core/v$(echo ${pkgver} | grep -Po "^[0-9]+\.[0-9]+")/files/textutils-v${pkgver}.tar.gz")
-sha256sums=('14a2f8393159fcc43bfac82d0100364dc874fee94447aced80ec8ae99e2949eb')
+sha256sums=('c0368fb6ad18727cd69fbfb20dd734fb7f7189707107d1f88d8de15837dc22df')
build() {
cd "${srcdir}/textutils-v${pkgver}"
- jbuilder build
+ dune build
}
package() {
cd "${srcdir}/textutils-v${pkgver}"
install -dm755 "${pkgdir}$(ocamlfind -printconf destdir)" "${pkgdir}/usr/share/"
- jbuilder install --prefix "${pkgdir}/usr" --libdir "${pkgdir}$(ocamlfind -printconf destdir)"
+ dune install --prefix "${pkgdir}/usr" --libdir "${pkgdir}$(ocamlfind -printconf destdir)"
mv "${pkgdir}/usr/doc" "${pkgdir}/usr/share/"
}