summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Peukert2024-01-28 00:14:40 +0100
committerDaniel Peukert2024-01-28 00:14:40 +0100
commitad3d18fed11120ce2bbf10dc83ea9ccd60a6e014 (patch)
tree53d19070685340acae3a7e595c2f07f3e6847a38
parent27f990c06639d63cb52bd7839269f8218f5fb874 (diff)
downloadaur-ad3d18fed11120ce2bbf10dc83ea9ccd60a6e014.tar.gz
Sync pkgbuilds repo with AUR
-rw-r--r--.gitignore28
-rw-r--r--PKGBUILD2
2 files changed, 15 insertions, 15 deletions
diff --git a/.gitignore b/.gitignore
index 82b3c183d5d4..076d904dd4ac 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,14 +1,14 @@
-# from https://github.com/github/gitignore/blob/master/ArchLinuxPackages.gitignore
-*.tar
-*.tar.*
-*.rpm
-*.jar
-*.exe
-*.msi
-*.zip
-*.tgz
-*.log
-*.log.*
-*.sig
-
-*/
+# Only exclude files from the root of the package repo, as some AUR helpers download sources into the directory of the repo,
+# which causes the gitignore file to apply to them too, which breaks some builds
+# Based on https://github.com/github/gitignore/blob/main/ArchLinuxPackages.gitignore
+/*.tar
+/*.tar.*
+/*.rpm
+/*.jar
+/*.exe
+/*.msi
+/*.zip
+/*.tgz
+/*.log
+/*.log.*
+/*.sig
diff --git a/PKGBUILD b/PKGBUILD
index 7edf0683db2b..34abd5d71362 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -32,5 +32,5 @@ package() {
done
install -dm755 "$pkgdir/usr/share/licenses/$pkgname"
- ln -sf "/usr/share/doc/$pkgname/LICENSE.md" "$pkgdir/usr/share/licenses/$pkgname/LICENSE.md"
+ ln -sf "/usr/share/doc/$pkgname/LICENSE.md" "$pkgdir/usr/share/licenses/$pkgname/MIT"
}