summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJakob Gahde2018-06-28 22:09:45 +0200
committerJakob Gahde2018-06-28 22:09:45 +0200
commitb6332378922e5f3a0607bc4458fca1be0973f678 (patch)
tree49df8d8f6bee8a88ae6123d62799ea3a8712c95f
downloadaur-b6332378922e5f3a0607bc4458fca1be0973f678.tar.gz
ocaml-textutils_kernel 0.11.0-1: New package
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD29
2 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f74522ce3ff5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+# Generated by mksrcinfo v8
+# Thu Jun 28 20:09:25 UTC 2018
+pkgbase = ocaml-textutils_kernel
+ pkgdesc = The subset of textutils using only core_kernel and working in javascript
+ pkgver = 0.11.0
+ pkgrel = 1
+ url = https://github.com/janestreet/textutils_kernel
+ arch = x86_64
+ license = Apache
+ makedepends = dune
+ depends = ocaml
+ depends = ocaml-core_kernel
+ depends = ocaml-ppx_jane
+ depends = ocaml-migrate-parsetree
+ depends = ocaml-ppxlib
+ options = !strip
+ source = https://ocaml.janestreet.com/ocaml-core/v0.11/files/textutils_kernel-v0.11.0.tar.gz
+ md5sums = eb06214c518996ec2a15d5c9975d6456
+
+pkgname = ocaml-textutils_kernel
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..21200d5c7c69
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Jakob Gahde <j5lx@fmail.co.uk>
+
+pkgname=ocaml-textutils_kernel
+pkgver=0.11.0
+pkgrel=1
+pkgdesc="The subset of textutils using only core_kernel and working in javascript"
+arch=('x86_64')
+url='https://github.com/janestreet/textutils_kernel'
+license=('Apache')
+depends=('ocaml' 'ocaml-core_kernel' 'ocaml-ppx_jane' 'ocaml-migrate-parsetree' 'ocaml-ppxlib')
+makedepends=('dune')
+options=('!strip')
+source=("https://ocaml.janestreet.com/ocaml-core/v$(echo ${pkgver} | grep -Po "^[0-9]+\.[0-9]+")/files/textutils_kernel-v${pkgver}.tar.gz")
+md5sums=('eb06214c518996ec2a15d5c9975d6456')
+
+build() {
+ cd "${srcdir}/textutils_kernel-v${pkgver}"
+
+ jbuilder build
+}
+
+
+package() {
+ cd "${srcdir}/textutils_kernel-v${pkgver}"
+
+ mkdir -p "${pkgdir}$(ocamlfind printconf destdir)" "${pkgdir}/usr/share"
+ jbuilder install --prefix "${pkgdir}/usr" --libdir "${pkgdir}$(ocamlfind printconf destdir)"
+ mv "${pkgdir}/usr/doc" "${pkgdir}/usr/share/"
+}