summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Peukert2023-08-11 13:12:37 +0200
committerDaniel Peukert2023-08-11 13:12:37 +0200
commit463e605acb30c32a6060c58a5d3aa64913ff0331 (patch)
tree8bb04d598f2d65639fda37555b3baab948b2aabf
parentc1166aae3ec10b6ff83bd13562b4a65b6215a165 (diff)
downloadaur-463e605acb30c32a6060c58a5d3aa64913ff0331.tar.gz
Update test/check comments
-rw-r--r--PKGBUILD5
1 files changed, 2 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9eb6785d46f5..ef0a472c7a73 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,6 @@ pkgname="ocaml-$_projectname"
pkgver='4.5.0'
pkgrel='1'
pkgdesc='A library for building correct HTML and SVG documents for OCaml'
-# If you're running on aarch64, you have to add it to the arch array of the cppo, ocaml-biniou, ocaml-cmdliner, ocaml-easy-format and ocaml-yojson AUR dependencies
arch=('x86_64' 'aarch64')
url="https://github.com/ocsigen/$_projectname"
license=('custom:LGPL2.1 with linking exception')
@@ -32,6 +31,8 @@ build() {
dune build --release --verbose
}
+# Not running tests because of a circular dependency on ocaml-js_of_ocaml
+
package() {
cd "$srcdir/$_sourcedirectory/"
DESTDIR="$pkgdir" dune install --prefix '/usr' --libdir '/usr/lib/ocaml' --docdir '/usr/share/doc' --mandir '/usr/share/man' --release --verbose
@@ -43,5 +44,3 @@ package() {
install -dm755 "$pkgdir/usr/share/licenses/$pkgname"
ln -sf "/usr/share/doc/$pkgname/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}
-
-# CHECK_DISABLED_CIRCULAR_DEP