summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Peukert2023-09-28 02:33:35 +0200
committerDaniel Peukert2023-09-28 02:33:35 +0200
commit8bcdef2abac96bcf1bde3c2b058685e7796eaa2c (patch)
tree42be52377e985ce2c11ddf6cfbc09cdbb75a9c75
parent463e605acb30c32a6060c58a5d3aa64913ff0331 (diff)
downloadaur-8bcdef2abac96bcf1bde3c2b058685e7796eaa2c.tar.gz
Update ocaml-tyxml to 4.6.0
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD21
-rw-r--r--ocaml5-compatibility.diff56
3 files changed, 10 insertions, 79 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8e34d27e4e3f..dc9a79b12239 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,22 +1,20 @@
pkgbase = ocaml-tyxml
pkgdesc = A library for building correct HTML and SVG documents for OCaml
- pkgver = 4.5.0
+ pkgver = 4.6.0
pkgrel = 1
url = https://github.com/ocsigen/tyxml
arch = x86_64
arch = aarch64
license = custom:LGPL2.1 with linking exception
- makedepends = dune>=2.0.0
+ makedepends = dune>=2.7.0
depends = ocaml>=4.04.0
depends = ocaml-markup>=0.7.2
- depends = ocaml-ppxlib
+ depends = ocaml-ppxlib>=0.18.0
depends = ocaml-re>=1.5.0
depends = ocaml-seq
depends = ocaml-uutf>=1.0.0
options = !strip
- source = ocaml-tyxml-4.5.0.tar.gz::https://github.com/ocsigen/tyxml/archive/4.5.0.tar.gz
- source = ocaml5-compatibility.diff
- sha512sums = 44591c4c32cb7e9425c1ca257624f12d6301709d33522672e13d28a6397da7e6b4eac0780e384763f26d5bc0e935a042d8224c22ea29a16d924f03a3c5b5a714
- sha512sums = 0a635e8d4fb3a4ffdafb51dc4e91151a32ea72b98664f2832be89d1922ba00e3c9fa0da4d23340a3d46571fa61758c22f540f9fc07eff27c24d14f86b68ea878
+ source = ocaml-tyxml-4.6.0.tar.gz::https://github.com/ocsigen/tyxml/archive/4.6.0.tar.gz
+ sha512sums = 25e07c55e04a1f4b02eea511625c1fbb138c168ba19f3b3d929c540d8dc7f96d9c2ec09bb221f592bf09610a542d66f3f8b9b930b1b824f4195e5e0b91b31088
pkgname = ocaml-tyxml
diff --git a/PKGBUILD b/PKGBUILD
index ef0a472c7a73..76007f37ddb6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,31 +1,20 @@
# Maintainer: Daniel Peukert <daniel@peukert.cc>
_projectname='tyxml'
pkgname="ocaml-$_projectname"
-pkgver='4.5.0'
+pkgver='4.6.0'
pkgrel='1'
pkgdesc='A library for building correct HTML and SVG documents for OCaml'
arch=('x86_64' 'aarch64')
url="https://github.com/ocsigen/$_projectname"
license=('custom:LGPL2.1 with linking exception')
-depends=('ocaml>=4.04.0' 'ocaml-markup>=0.7.2' 'ocaml-ppxlib' 'ocaml-re>=1.5.0' 'ocaml-seq' 'ocaml-uutf>=1.0.0')
-makedepends=('dune>=2.0.0')
+depends=('ocaml>=4.04.0' 'ocaml-markup>=0.7.2' 'ocaml-ppxlib>=0.18.0' 'ocaml-re>=1.5.0' 'ocaml-seq' 'ocaml-uutf>=1.0.0')
+makedepends=('dune>=2.7.0')
options=('!strip')
-source=(
- "$pkgname-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz"
- 'ocaml5-compatibility.diff'
-)
-sha512sums=('44591c4c32cb7e9425c1ca257624f12d6301709d33522672e13d28a6397da7e6b4eac0780e384763f26d5bc0e935a042d8224c22ea29a16d924f03a3c5b5a714'
- '0a635e8d4fb3a4ffdafb51dc4e91151a32ea72b98664f2832be89d1922ba00e3c9fa0da4d23340a3d46571fa61758c22f540f9fc07eff27c24d14f86b68ea878')
+source=("$pkgname-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz")
+sha512sums=('25e07c55e04a1f4b02eea511625c1fbb138c168ba19f3b3d929c540d8dc7f96d9c2ec09bb221f592bf09610a542d66f3f8b9b930b1b824f4195e5e0b91b31088')
_sourcedirectory="$_projectname-$pkgver"
-prepare() {
- cd "$srcdir/$_sourcedirectory/"
-
- # Fix ocaml 5 compatibility (based on https://github.com/ocsigen/tyxml/commit/2f2faf3bc2fb0be5a9c0bd2f2f440a98dde73f80)
- patch --forward -p1 < '../ocaml5-compatibility.diff'
-}
-
build() {
cd "$srcdir/$_sourcedirectory/"
dune build --release --verbose
diff --git a/ocaml5-compatibility.diff b/ocaml5-compatibility.diff
deleted file mode 100644
index 05ed3ae9cbac..000000000000
--- a/ocaml5-compatibility.diff
+++ /dev/null
@@ -1,56 +0,0 @@
-diff --git a/jsx/tyxml_jsx.ml b/jsx/tyxml_jsx.ml
-index 1b47b989..9b80f468 100644
---- a/jsx/tyxml_jsx.ml
-+++ b/jsx/tyxml_jsx.ml
-@@ -9,16 +9,6 @@ let is_jsx e =
- in
- List.exists f e.pexp_attributes
-
--(* When dropping support for 4.02, this module can simply be deleted. *)
--module String = struct
-- include String
-- let lowercase_ascii = String.lowercase [@ocaml.warning "-3"]
--end
--module Char = struct
-- include Char
-- let lowercase_ascii = Char.lowercase [@ocaml.warning "-3"]
--end
--
- let lowercase_lead s =
- String.mapi (fun i c -> if i = 0 then Char.lowercase_ascii c else c) s
-
-diff --git a/ppx/tyxml_ppx.ml b/ppx/tyxml_ppx.ml
-index a5ff80d1..5319c123 100644
---- a/ppx/tyxml_ppx.ml
-+++ b/ppx/tyxml_ppx.ml
-@@ -19,12 +19,6 @@
-
- open Tyxml_syntax
-
--(* When dropping support for 4.02, this module can simply be deleted. *)
--module String = struct
-- include String
-- let capitalize_ascii = String.capitalize [@ocaml.warning "-3"]
--end
--
- open Ppxlib.Asttypes
- open Ppxlib.Parsetree
-
-diff --git a/syntax/name_convention.ml b/syntax/name_convention.ml
-index 3dd3abd3..419d5911 100644
---- a/syntax/name_convention.ml
-+++ b/syntax/name_convention.ml
-@@ -4,13 +4,6 @@
- see <http://www.w3.org/TR/html51/syntax.html#syntax>
- *)
-
--(* When dropping support for 4.02, this module can simply be deleted. *)
--module Char = struct
-- include Char
-- let lowercase_ascii = Char.lowercase [@ocaml.warning "-3"]
-- let uppercase_ascii = Char.uppercase [@ocaml.warning "-3"]
--end
--
- (* In the ocaml parser:
- let identchar = ['A'-'Z' 'a'-'z' '_' '\'' '0'-'9']
- *)