summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMoritz Kaspar Rudert (mortzu)2019-11-29 20:39:24 +0100
committerMoritz Kaspar Rudert (mortzu)2019-11-29 20:39:24 +0100
commit5df7387d392a86003206f748bb52b90484ef9858 (patch)
treeee459e4d545964e0bf5fd12ada5bf4adf3ad799a
downloadaur-5df7387d392a86003206f748bb52b90484ef9858.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD31
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d5a7d67dfd50
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = ocaml-uchar
+ pkgdesc = Compatibility library for OCaml's Uchar module
+ pkgver = 0.0.2
+ pkgrel = 0
+ url = https://github.com/ocaml/uchar
+ arch = i686
+ arch = x86_64
+ license = LGPL-2.1-WITH-linking-exception
+ makedepends = ocaml
+ makedepends = ocamlbuild
+ makedepends = opam
+ depends = ocaml
+ source = ocaml-uchar-0.0.2.tar.gz::https://github.com/ocaml/uchar/archive/v0.0.2.tar.gz
+ sha512sums = 487a9706cf9dfc9b9c94442a51766cc211687d6ebcb4dd3c94d09cb1ed6d7fd61e966e91a4121fe2d1681b2fd6bfee9079d3bccccdb6d65ba2111524ab5dd1bc
+
+pkgname = ocaml-uchar
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..75779e1d0f97
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# NOTE: This is just a dummy module to satisfy dependencies, uchar is provided
+# directly by ocaml since 4.03.
+pkgname=ocaml-uchar
+_pkgname=uchar
+pkgver=0.0.2
+pkgrel=0
+pkgdesc="Compatibility library for OCaml's Uchar module"
+url="https://github.com/ocaml/uchar"
+arch=('i686' 'x86_64')
+license=('LGPL-2.1-WITH-linking-exception')
+depends=('ocaml')
+makedepends=('ocaml' 'ocamlbuild' 'opam')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/ocaml/uchar/archive/v$pkgver.tar.gz")
+sha512sums=("487a9706cf9dfc9b9c94442a51766cc211687d6ebcb4dd3c94d09cb1ed6d7fd61e966e91a4121fe2d1681b2fd6bfee9079d3bccccdb6d65ba2111524ab5dd1bc")
+
+build() {
+ cd "$srcdir/$_pkgname-$pkgver"
+
+ ocaml pkg/build.ml \
+ native=true \
+ native-dynlink=true
+}
+
+package() {
+ cd "$srcdir/$_pkgname-$pkgver"
+
+ opam-installer -i \
+ --prefix="$pkgdir/usr" \
+ --libdir="$pkgdir/usr/lib/ocaml" \
+ $_pkgname.install
+}