summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorwenLiangcan2015-06-10 15:19:09 +0800
committerwenLiangcan2015-06-10 15:19:21 +0800
commit432574897dbafb0758147615ab7c385a83b4363d (patch)
treeb0a1c1a4dcf12697246f785fd4dcdba91a692152
downloadaur-432574897dbafb0758147615ab7c385a83b4363d.tar.gz
ocaml-utop 1.17-1.
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD35
2 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f05683795b62
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = ocaml-utop
+ pkgdesc = A toplevel for OCaml that supports completion, colors, and parenthesis matching
+ pkgver = 1.17
+ pkgrel = 1
+ url = https://github.com/diml/utop
+ arch = i686
+ arch = x86_64
+ license = BSD
+ depends = ocaml>=4.01.0
+ depends = ocaml-lambda-term>=1.2
+ depends = cppo>=1.0.1
+ depends = ocaml-findlib
+ depends = ocaml-zed>=1.2
+ depends = ocaml-zed<=1.3
+ options = !strip
+ source = https://github.com/diml/utop/archive/1.17.tar.gz
+ md5sums = 79dcabf1b3704ee11bc55cdd92a8490c
+
+pkgname = ocaml-utop
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..34fd209b3a77
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: wenLiangcan <boxeed at gmail dot com>
+# Contributor: Taylor Venable <taylor@metasyntax.net>
+
+srcname='utop'
+pkgname="ocaml-${srcname}"
+pkgver='1.17'
+pkgrel=1
+pkgdesc='A toplevel for OCaml that supports completion, colors, and parenthesis matching'
+arch=('i686' 'x86_64')
+url='https://github.com/diml/utop'
+license=('BSD')
+depends=('ocaml>=4.01.0' 'ocaml-lambda-term>=1.2' 'cppo>=1.0.1' 'ocaml-findlib' 'ocaml-zed>=1.2' 'ocaml-zed<=1.3')
+source=("https://github.com/diml/utop/archive/${pkgver}.tar.gz")
+options=('!strip')
+md5sums=('79dcabf1b3704ee11bc55cdd92a8490c')
+
+build() {
+ cd "$srcdir/${srcname}-${pkgver}"
+ ./configure --prefix /usr --destdir "$pkgdir" --enable-camlp4
+
+ env DESTDIR="$pkgdir" \
+ OCAMLFIND_DESTDIR="$pkgdir/$(ocamlfind printconf destdir)" \
+ make
+}
+
+
+package() {
+ install -dm755 "$pkgdir/$(ocamlfind printconf destdir)"
+ install -dm755 "$pkgdir/$(ocamlfind printconf destdir)/stublibs"
+ cd "$srcdir/${srcname}-${pkgver}"
+ env DESTDIR="$pkgdir" \
+ OCAMLFIND_DESTDIR="$pkgdir/$(ocamlfind printconf destdir)" \
+ make install
+ install -Dm 644 LICENSE $pkgdir/usr/share/licenses/$pkgname/LICENSE
+}