summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Peukert2020-05-30 11:29:40 +0200
committerDaniel Peukert2020-05-30 11:29:40 +0200
commit6a808c35eb33cc29893ab8bf03535a91b46b8654 (patch)
tree41b9d9711bf37236ffc6664b6403c4ade1cfb669
parenta8e8665e5d5e884fda33973c5900fe2a466da2e7 (diff)
downloadaur-6a808c35eb33cc29893ab8bf03535a91b46b8654.tar.gz
Updated ocaml-utop to 2.6.0
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD12
2 files changed, 11 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2d22263d0339..86ca49336ac4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = ocaml-utop
pkgdesc = Universal toplevel for OCaml
- pkgver = 2.5.0
- pkgrel = 2
+ pkgver = 2.6.0
+ pkgrel = 1
url = https://github.com/ocaml-community/utop
arch = x86_64
arch = i686
@@ -15,11 +15,11 @@ pkgbase = ocaml-utop
depends = ocaml>=4.03.0
depends = ocaml-camomile
depends = ocaml-findlib>=1.7.2
- depends = ocaml-lambda-term>=3.0.0
+ depends = ocaml-lambda-term>=3.1.0
depends = ocaml-lwt
depends = ocaml-react>=1.0.0
options = !strip
- source = ocaml-utop-2.5.0-2.tar.gz::https://github.com/ocaml-community/utop/archive/2.5.0.tar.gz
- sha256sums = bc4170cb455c52ee8915d7139b3ed6fef13eb124a1171e8f719bb090effc6e7f
+ source = ocaml-utop-2.6.0-1.tar.gz::https://github.com/ocaml-community/utop/archive/2.6.0.tar.gz
+ sha256sums = b8c2fe5762c04a1c9b4831fa39d92b7480608a2235c73c748ba629b3c017fa02
pkgname = ocaml-utop
diff --git a/PKGBUILD b/PKGBUILD
index 511f4c315ab3..dcd96379dbb1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,17 +4,17 @@
# Contributor: Taylor Venable <taylor@metasyntax.net>
_projectname='utop'
pkgname="ocaml-$_projectname"
-pkgver='2.5.0'
-pkgrel='2'
+pkgver='2.6.0'
+pkgrel='1'
pkgdesc='Universal toplevel for OCaml'
arch=('x86_64' 'i686' 'arm' 'armv6h' 'armv7h' 'aarch64')
url="https://github.com/ocaml-community/$_projectname"
license=('BSD')
-depends=('ocaml>=4.03.0' 'ocaml-camomile' 'ocaml-findlib>=1.7.2' 'ocaml-lambda-term>=3.0.0' 'ocaml-lwt' 'ocaml-react>=1.0.0')
+depends=('ocaml>=4.03.0' 'ocaml-camomile' 'ocaml-findlib>=1.7.2' 'ocaml-lambda-term>=3.1.0' 'ocaml-lwt' 'ocaml-react>=1.0.0')
makedepends=('cppo>=1.1.2' 'dune>=1.0.0')
options=('!strip')
source=("$pkgname-$pkgver-$pkgrel.tar.gz::$url/archive/$pkgver.tar.gz")
-sha256sums=('bc4170cb455c52ee8915d7139b3ed6fef13eb124a1171e8f719bb090effc6e7f')
+sha256sums=('b8c2fe5762c04a1c9b4831fa39d92b7480608a2235c73c748ba629b3c017fa02')
_sourcedirectory="$_projectname-$pkgver"
@@ -25,12 +25,12 @@ prepare() {
build() {
cd "$srcdir/$_sourcedirectory/"
- dune build -p "$_projectname" --verbose
+ dune build --release --verbose
}
package() {
cd "$srcdir/$_sourcedirectory/"
- DESTDIR="$pkgdir" dune install --prefix '/usr' --libdir 'lib/ocaml'
+ DESTDIR="$pkgdir" dune install --prefix '/usr' --libdir 'lib/ocaml' --release --verbose
install -dm755 "$pkgdir/usr/share/doc/$pkgname"
mv "$pkgdir/usr/doc/$_projectname/"* "$pkgdir/usr/share/doc/$pkgname/"