summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJakob Gahde2016-10-30 11:18:54 +0100
committerJakob Gahde2016-10-30 11:18:54 +0100
commit9489a3c8eea8f85eb79f06acf20b09b08de1fb68 (patch)
tree49ce53ca79a22f0ebee89021fff017bad09782e0
parent9299385ee0a4d9ddad5ee31b5377fe0e8cba50f8 (diff)
downloadaur-9489a3c8eea8f85eb79f06acf20b09b08de1fb68.tar.gz
ocaml-utop 1.19.3: New version
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD12
2 files changed, 9 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bd5417a93699..9f27464394b8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Tue Jun 21 16:43:50 UTC 2016
+# Sun Oct 30 10:18:34 UTC 2016
pkgbase = ocaml-utop
pkgdesc = A toplevel for OCaml that supports completion, colors, and parenthesis matching
- pkgver = 1.19.2
+ pkgver = 1.19.3
pkgrel = 1
url = https://github.com/diml/utop
arch = i686
@@ -16,8 +16,8 @@ pkgbase = ocaml-utop
depends = ocaml-react
depends = camlp4
options = !strip
- source = https://github.com/diml/utop/archive/1.19.2.tar.gz
- md5sums = 0f65ab4a47cb200da4491e5866a53e4e
+ source = https://github.com/diml/utop/archive/1.19.3.tar.gz
+ md5sums = 280f9a1062c53be8bae41cfd57ce29dd
pkgname = ocaml-utop
diff --git a/PKGBUILD b/PKGBUILD
index 95fb8d41e09e..d9edf494835c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
_pkgname='utop'
pkgname="ocaml-${_pkgname}"
-pkgver=1.19.2
+pkgver=1.19.3
pkgrel=1
pkgdesc='A toplevel for OCaml that supports completion, colors, and parenthesis matching'
arch=('i686' 'x86_64')
@@ -13,7 +13,7 @@ license=('BSD')
depends=('ocaml' 'cppo' 'ocaml-lambda-term' 'ocaml-lwt' 'ocaml-findlib' 'ocaml-react' 'camlp4')
source=("https://github.com/diml/utop/archive/${pkgver}.tar.gz")
options=('!strip')
-md5sums=('0f65ab4a47cb200da4491e5866a53e4e')
+md5sums=('280f9a1062c53be8bae41cfd57ce29dd')
build() {
cd "${srcdir}/${_pkgname}-${pkgver}"
@@ -27,10 +27,8 @@ build() {
package() {
cd "${srcdir}/${_pkgname}-${pkgver}"
- OCAMLFIND_DESTDIR="${pkgdir}$(ocamlfind printconf destdir)"
- mkdir -p "${OCAMLFIND_DESTDIR}"
- DESTDIR="${pkgdir}" \
- OCAMLFIND_DESTDIR="${OCAMLFIND_DESTDIR}" \
- make install
+ export OCAMLFIND_DESTDIR="${pkgdir}$(ocamlfind printconf destdir)"
+ install -dm755 "${OCAMLFIND_DESTDIR}"
+ make install
install -Dm644 "LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}