summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJ5lx2015-12-02 18:14:17 +0100
committerJ5lx2015-12-02 18:14:17 +0100
commitc600f95362ed1802b59b5911fa0334f0ec088a29 (patch)
tree5744387320a7d1aedec1ccd52c07d06f5aec0d8d
parent1bd1af4d73828e9034b6fda5756a5514ab03b6e2 (diff)
downloadaur-c600f95362ed1802b59b5911fa0334f0ec088a29.tar.gz
1.18.1-1: New version
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD37
2 files changed, 28 insertions, 23 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 374b02c0925f..de0e8dbad0f2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,23 @@
pkgbase = ocaml-utop
pkgdesc = A toplevel for OCaml that supports completion, colors, and parenthesis matching
- pkgver = 1.18
+ pkgver = 1.18.1
pkgrel = 1
url = https://github.com/diml/utop
arch = i686
arch = x86_64
license = BSD
depends = ocaml>=4.01.0
- depends = ocaml-lambda-term>=1.2
+ depends = ocaml-findlib>=1.4.0
depends = cppo>=1.0.1
- depends = ocaml-findlib
+ depends = ocaml-react
+ depends = ocaml-lwt>=2.4.0
+ depends = ocaml-camomile>=0.8
depends = ocaml-zed>=1.2
+ depends = ocaml-lambda-term>=1.2
+ depends = camlp4
options = !strip
- source = https://github.com/diml/utop/archive/1.18.tar.gz
- md5sums = ccb0fdd55ac9a5df113a2a38f9d26f0a
+ source = https://github.com/diml/utop/archive/1.18.1.tar.gz
+ md5sums = d943512656806c06ecf327c37c9aa831
pkgname = ocaml-utop
diff --git a/PKGBUILD b/PKGBUILD
index 39860f0db9f5..257de2bafecf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,35 +1,36 @@
-# Maintainer: wenLiangcan <boxeed at gmail dot com>
+# Maintainer: Jakob Gahde <j5lx@fmail.co.uk>
+# Contributor: wenLiangcan <boxeed at gmail dot com>
# Contributor: Taylor Venable <taylor@metasyntax.net>
-srcname='utop'
-pkgname="ocaml-${srcname}"
-pkgver=1.18
+_pkgname='utop'
+pkgname="ocaml-${_pkgname}"
+pkgver=1.18.1
pkgrel=1
pkgdesc='A toplevel for OCaml that supports completion, colors, and parenthesis matching'
arch=('i686' 'x86_64')
url='https://github.com/diml/utop'
license=('BSD')
-depends=('ocaml>=4.01.0' 'ocaml-lambda-term>=1.2' 'cppo>=1.0.1' 'ocaml-findlib' 'ocaml-zed>=1.2')
+depends=('ocaml>=4.01.0' 'ocaml-findlib>=1.4.0' 'cppo>=1.0.1' 'ocaml-react' 'ocaml-lwt>=2.4.0' 'ocaml-camomile>=0.8' 'ocaml-zed>=1.2' 'ocaml-lambda-term>=1.2' 'camlp4')
source=("https://github.com/diml/utop/archive/${pkgver}.tar.gz")
options=('!strip')
-md5sums=('ccb0fdd55ac9a5df113a2a38f9d26f0a')
+md5sums=('d943512656806c06ecf327c37c9aa831')
build() {
- cd "$srcdir/${srcname}-${pkgver}"
- ./configure --prefix /usr --destdir "$pkgdir" --enable-camlp4
+ cd "${srcdir}/${_pkgname}-${pkgver}"
- env DESTDIR="$pkgdir" \
- OCAMLFIND_DESTDIR="$pkgdir/$(ocamlfind printconf destdir)" \
- make
+ ./configure --prefix /usr --destdir "${pkgdir}" --enable-camlp4
+
+ make
}
package() {
- install -dm755 "$pkgdir/$(ocamlfind printconf destdir)"
- install -dm755 "$pkgdir/$(ocamlfind printconf destdir)/stublibs"
- cd "$srcdir/${srcname}-${pkgver}"
- env DESTDIR="$pkgdir" \
- OCAMLFIND_DESTDIR="$pkgdir/$(ocamlfind printconf destdir)" \
- make install
- install -Dm 644 LICENSE $pkgdir/usr/share/licenses/$pkgname/LICENSE
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+
+ OCAMLFIND_DESTDIR="${pkgdir}$(ocamlfind printconf destdir)"
+ mkdir -p "${OCAMLFIND_DESTDIR}"
+ DESTDIR="${pkgdir}" \
+ OCAMLFIND_DESTDIR="${OCAMLFIND_DESTDIR}" \
+ make install
+ install -Dm644 "LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}