summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJakob Gahde2018-06-28 00:34:14 +0200
committerJakob Gahde2018-06-28 00:34:14 +0200
commitf28a50bc516c1b229f2618d5a7ae520b0855396c (patch)
tree9cd1cd81ca0d2b68322941d4dd1024ca3b8d37ff
parentcf4c840c31501eab0a505fc8e64bac87a5045c5d (diff)
downloadaur-f28a50bc516c1b229f2618d5a7ae520b0855396c.tar.gz
ocaml-utop 2.1.0-1: New version
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD27
2 files changed, 21 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8a0ef1b179b7..9ca173c95d39 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,23 +1,24 @@
# Generated by mksrcinfo v8
-# Sun Jul 16 10:55:28 UTC 2017
+# Wed Jun 27 22:33:30 UTC 2018
pkgbase = ocaml-utop
pkgdesc = A toplevel for OCaml that supports completion, colors, and parenthesis matching
- pkgver = 1.19.3
+ pkgver = 2.1.0
pkgrel = 1
url = https://github.com/diml/utop
arch = i686
arch = x86_64
license = BSD
+ makedepends = dune
+ makedepends = cppo
depends = ocaml
- depends = cppo
+ depends = ocaml-findlib
depends = ocaml-lambda-term
depends = ocaml-lwt
- depends = ocaml-findlib
+ depends = ocaml-camomile
depends = ocaml-react
- depends = camlp4
options = !strip
- source = https://github.com/diml/utop/archive/1.19.3.tar.gz
- md5sums = 280f9a1062c53be8bae41cfd57ce29dd
+ source = https://github.com/diml/utop/releases/download/2.1.0/utop-2.1.0.tbz
+ md5sums = 6c63a321379069a1b9ecb7899f80087b
pkgname = ocaml-utop
diff --git a/PKGBUILD b/PKGBUILD
index 73d41237fb26..7c1bf7290454 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,33 +2,32 @@
# Contributor: wenLiangcan <boxeed at gmail dot com>
# Contributor: Taylor Venable <taylor@metasyntax.net>
-_pkgname='utop'
-pkgname="ocaml-${_pkgname}"
-pkgver=1.19.3
+pkgname="ocaml-utop"
+pkgver=2.1.0
pkgrel=1
pkgdesc='A toplevel for OCaml that supports completion, colors, and parenthesis matching'
arch=('i686' 'x86_64')
url='https://github.com/diml/utop'
license=('BSD')
-depends=('ocaml' 'cppo' 'ocaml-lambda-term' 'ocaml-lwt' 'ocaml-findlib' 'ocaml-react' 'camlp4')
+depends=('ocaml' 'ocaml-findlib' 'ocaml-lambda-term' 'ocaml-lwt' 'ocaml-camomile' 'ocaml-react')
+makedepends=('dune' 'cppo')
options=('!strip')
-source=("https://github.com/diml/utop/archive/${pkgver}.tar.gz")
-md5sums=('280f9a1062c53be8bae41cfd57ce29dd')
+source=("https://github.com/diml/utop/releases/download/${pkgver}/utop-${pkgver}.tbz")
+md5sums=('6c63a321379069a1b9ecb7899f80087b')
build() {
- cd "${srcdir}/${_pkgname}-${pkgver}"
+ cd "${srcdir}/utop-${pkgver}"
- ./configure --prefix /usr --destdir "${pkgdir}" --enable-camlp4
-
- make
+ jbuilder build
}
package() {
- cd "${srcdir}/${_pkgname}-${pkgver}"
+ cd "${srcdir}/utop-${pkgver}"
- export OCAMLFIND_DESTDIR="${pkgdir}$(ocamlfind printconf destdir)"
- install -dm755 "${OCAMLFIND_DESTDIR}"
- make install
+ install -dm755 "${pkgdir}$(ocamlfind -printconf destdir)" "${pkgdir}/usr/share"
+ jbuilder install --prefix "${pkgdir}/usr" --libdir "${pkgdir}$(ocamlfind -printconf destdir)"
+ mv "${pkgdir}/usr/doc" "${pkgdir}/usr/share/"
+ mv "${pkgdir}/usr/man" "${pkgdir}/usr/share/"
install -Dm644 "LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}