summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJ5lx2015-10-10 18:37:55 +0200
committerJ5lx2015-10-10 18:37:55 +0200
commit848ee8485ae6211c750da6ee968956baad44029d (patch)
tree05186f429104a696eba73d0beea855f952edfdf7
downloadaur-848ee8485ae6211c750da6ee968956baad44029d.tar.gz
0.1.1-1: Initial package
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD29
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5c586590c2e2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = ocaml-voaacenc
+ pkgdesc = OCaml bindings for the vo-aacenc AAC encoder
+ pkgver = 0.1.1
+ pkgrel = 1
+ url = https://github.com/savonet/ocaml-voaacenc
+ arch = i686
+ arch = x86_64
+ license = LGPL2.1
+ makedepends = ocaml-findlib
+ depends = ocaml
+ depends = vo-aacenc
+ options = !strip
+ source = https://github.com/savonet/ocaml-voaacenc/releases/download/0.1.1/ocaml-voaacenc-0.1.1.tar.gz
+ md5sums = 9fc233686c26a0ec96b8a9144dc8d95b
+
+pkgname = ocaml-voaacenc
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..aa471469e3f7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Jakob Gahde <j5lx@fmail.co.uk>
+
+pkgname=ocaml-voaacenc
+pkgver=0.1.1
+pkgrel=1
+license=('LGPL2.1')
+arch=('i686' 'x86_64')
+pkgdesc=("OCaml bindings for the vo-aacenc AAC encoder")
+url="https://github.com/savonet/ocaml-voaacenc"
+depends=('ocaml' 'vo-aacenc')
+makedepends=('ocaml-findlib')
+source=("https://github.com/savonet/ocaml-voaacenc/releases/download/${pkgver}/${pkgname}-${pkgver}.tar.gz")
+options=('!strip')
+md5sums=('9fc233686c26a0ec96b8a9144dc8d95b')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ ./configure
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ export OCAMLFIND_DESTDIR="${pkgdir}$(ocamlfind printconf destdir)"
+ mkdir -p "${OCAMLFIND_DESTDIR}/stublibs"
+ make install
+}