summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorrobinleander2018-07-26 18:57:04 +0200
committerrobinleander2018-07-26 18:57:04 +0200
commita6e5c1e444dda7046be2ad58b1753a1dad67882d (patch)
tree76a32ccb29ecb6d4bdf8ce48d5a1ecec0b6a979b
downloadaur-a6e5c1e444dda7046be2ad58b1753a1dad67882d.tar.gz
Update package
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD26
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..49e67bbcb1d8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = ocaml-wasm
+ pkgdesc = An OCaml library to read and write Web Assembly (wasm) files and manipulate their AST.
+ pkgver = 1.0
+ pkgrel = 1
+ arch = i686
+ arch = x86_64
+ license = unknown
+ options = !strip
+ options = !makeflags
+ options = staticlibs
+ source = https://github.com/WebAssembly/spec/archive/v1.0.zip
+ md5sums = 82d4cc7c67ae32a6785268a1cdddd973
+
+pkgname = ocaml-wasm
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bb401543787f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: crave <crave@noreply>
+# Generated by opam2aur https://gitlab.com/malet/opam2aur
+
+pkgname=ocaml-wasm
+_oname=wasm
+pkgver=1.0
+pkgrel=1
+pkgdesc="An OCaml library to read and write Web Assembly (wasm) files and manipulate their AST."
+arch=('i686' 'x86_64')
+url=''
+license=('unknown')
+options=('!strip' '!makeflags' 'staticlibs')
+source=('https://github.com/WebAssembly/spec/archive/v1.0.zip')
+md5sums=('82d4cc7c67ae32a6785268a1cdddd973')
+
+build() {
+ cd "$srcdir/$_oname-$pkgver"
+ make -C src
+}
+
+package() {
+ cd "$srcdir/$_oname-$pkgver"
+ export OCAMLFIND_DESTDIR="$pkgdir$(ocamlfind printconf destdir)"
+ install -dm 755 "$OCAMLFIND_DESTDIR"
+ make -C src install
+}