summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorOliver Bandel2015-06-10 01:00:41 +0200
committerOliver Bandel2015-06-10 01:00:41 +0200
commit8f5562ea396b3d4df5faa980372b2cc665922d4f (patch)
treeb31efefec60718ac32a8cb2dbe0dc58acdb561d8
downloadaur-8f5562ea396b3d4df5faa980372b2cc665922d4f.tar.gz
Initial import
-rw-r--r--.SRCINFO20
-rw-r--r--META5
-rw-r--r--PKGBUILD37
3 files changed, 62 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..04e5c4016b98
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = ocaml-xml-light
+ pkgdesc = Objective Caml lightweight xml parser
+ pkgver = 2.2
+ pkgrel = 4
+ url = http://tech.motion-twin.com/xmllight.html
+ arch = i686
+ arch = x86_64
+ license = LGPL
+ makedepends = ocaml-findlib
+ depends = ocaml
+ options = !strip
+ options = !makeflags
+ options = staticlibs
+ source = http://tech.motion-twin.com/zip/xml-light-2.2.zip
+ source = META
+ md5sums = 7658985cfdaeeb94b579b932eeaa3e00
+ md5sums = ad22cde4d3a944673d3b0a25a1e835dc
+
+pkgname = ocaml-xml-light
+
diff --git a/META b/META
new file mode 100644
index 000000000000..f7ecefc084fb
--- /dev/null
+++ b/META
@@ -0,0 +1,5 @@
+name="xml-light"
+version="2.2"
+directory="+xml-light"
+archive(byte)="xml-light.cma"
+archive(native)="xml-light.cmxa"
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e22f00e6ac3a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: oliver <at> first . in - berlin . de
+
+pkgname=ocaml-xml-light
+pkgver=2.2
+pkgrel=4
+license=('LGPL')
+arch=('i686' 'x86_64')
+pkgdesc="Objective Caml lightweight xml parser"
+url="http://tech.motion-twin.com/xmllight.html"
+depends=('ocaml')
+makedepends=('ocaml-findlib')
+options=('!strip' '!makeflags' 'staticlibs')
+source=("http://tech.motion-twin.com/zip/xml-light-${pkgver}.zip"
+ "META")
+md5sums=('7658985cfdaeeb94b579b932eeaa3e00'
+ 'ad22cde4d3a944673d3b0a25a1e835dc')
+
+OCAMLFIND_DESTDIR="${pkgdir}$(ocamlfind printconf destdir)"
+DOCDIR="${pkgdir}/usr/share/doc/${pkgname}"
+
+build() {
+cd ${srcdir}/xml-light
+make all doc
+make opt
+}
+
+package() {
+cd ${srcdir}/xml-light
+mkdir -p ${pkgdir}$(ocamlfind printconf destdir)
+mkdir -p ${pkgdir}/usr/share/doc/${pkgname}
+rm -rf test.cmi
+cp ${srcdir}/META .
+env DESTDIR="${pkgdir}" \
+OCAMLFIND_DESTDIR=${pkgdir}$(ocamlfind printconf destdir) \
+ocamlfind install xml-light META *.mli *.cmi *.cma *.a *.cmxa *.cmx
+cp doc/* ${pkgdir}/usr/share/doc/${pkgname}
+}