summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorcondy2022-06-17 19:57:58 +0800
committercondy2022-06-17 19:57:58 +0800
commit83d2c77494d9d070f5ce88fc45433f50f5cb8761 (patch)
tree6b2ccd2405ef2042005117f3b316b1eb9b56bdfd
parent7db928251b9a8753934e92c79127c05b84bf7d4c (diff)
downloadaur-83d2c77494d9d070f5ce88fc45433f50f5cb8761.tar.gz
Update to 2.0.0
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD18
2 files changed, 16 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ee222041be84..f43d2793aea0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = ocaml-yojson
pkgdesc = Low level JSON binary for OCaml
- pkgver = 1.7.0
- pkgrel = 3
+ pkgver = 2.0.0
+ pkgrel = 1
url = https://github.com/ocaml-community/yojson
arch = x86_64
license = BSD
@@ -13,8 +13,7 @@ pkgbase = ocaml-yojson
conflicts = ocaml-yojson
options = !strip
options = staticlibs
- source = https://github.com/ocaml-community/yojson/releases/download/1.7.0/yojson-1.7.0.tbz
+ source = https://github.com/ocaml-community/yojson/releases/download/2.0.0/yojson-2.0.0.tbz
sha256sums = 656fc65f794186274f8b961dc38daba9e2de2fc993829291defbda2186812cc6
pkgname = ocaml-yojson
-
diff --git a/PKGBUILD b/PKGBUILD
index e539cb6a82de..f160ded8ae68 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,8 +3,8 @@
_pkgname=yojson
pkgname=ocaml-${_pkgname}
-pkgver=1.7.0
-pkgrel=3
+pkgver=2.0.0
+pkgrel=1
pkgdesc="Low level JSON binary for OCaml"
arch=('x86_64')
url="https://github.com/ocaml-community/${_pkgname}"
@@ -12,20 +12,28 @@ license=('BSD')
options=('!strip' 'staticlibs')
provides=('ocaml-yojson')
conflicts=('ocaml-yojson')
-depends=('ocaml-biniou' 'ocaml-easy-format')
+depends=()
makedepends=('dune' 'cppo')
source=(https://github.com/ocaml-community/${_pkgname}/releases/download/${pkgver}/${_pkgname}-${pkgver}.tbz)
-sha256sums=('656fc65f794186274f8b961dc38daba9e2de2fc993829291defbda2186812cc6')
+sha256sums=('ab5d863f7f951a8f7fb4a708399ca2da2cf139a5e0af7818145c20295420cb1a')
build() {
cd ${_pkgname}-${pkgver}
+
+ # Since we're using ocaml latest, at least 4.13.1
+ sed -i '/(libraries seq)/d' lib/dune
+
+ # No need to build the benchmarks
+ rm yojson-bench.opam
+ rm -r bench/
+
make all
}
package() {
cd ${_pkgname}-${pkgver}
- DESTDIR="${pkgdir}" dune install --prefix=/usr --libdir="lib/ocaml"
+ DESTDIR="${pkgdir}" dune install --prefix=/usr --libdir="/usr/lib/ocaml"
# remove rogue dune-package file
rm -r "${pkgdir}"/usr/doc