summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Peukert2022-06-14 20:47:02 +0200
committerDaniel Peukert2022-06-14 20:47:02 +0200
commit8206fa02e35f73d97ef617e2b2df4780f1adf7a8 (patch)
tree62e6363ba1388cd13c45e3fe38bee38a74955466
parentdde11ae846b07732e9ae95b3c0e212712561ea6d (diff)
downloadaur-8206fa02e35f73d97ef617e2b2df4780f1adf7a8.tar.gz
Fix dun calls, sha256 -> sha512
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD10
2 files changed, 6 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9c429a19f6d2..7cca3d5b3c10 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = ocaml-zed
pkgdesc = Abstract engine for text edition in OCaml
pkgver = 3.1.0
- pkgrel = 3
+ pkgrel = 4
url = https://github.com/ocaml-community/zed
arch = x86_64
arch = i686
@@ -16,7 +16,7 @@ pkgbase = ocaml-zed
depends = ocaml-react
depends = ocaml-charinfo_width>=1.1.0
options = !strip
- source = ocaml-zed-3.1.0-3.tar.gz::https://github.com/ocaml-community/zed/archive/3.1.0.tar.gz
- sha256sums = c387b0496c34c7eb680999e751525992e3e636a803297480ef004498887625fd
+ source = ocaml-zed-3.1.0-4.tar.gz::https://github.com/ocaml-community/zed/archive/3.1.0.tar.gz
+ sha512sums = d4457af15f970adb7b1ed543017e590fa0ecc47171d6dd520a1397f21ce0219caa30a9db7bedb76c0602d4f6d0f0684012cc33feafe18b848d3261a460dea10a
pkgname = ocaml-zed
diff --git a/PKGBUILD b/PKGBUILD
index a7a6054d2224..12208dcfc0f1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
_projectname='zed'
pkgname="ocaml-$_projectname"
pkgver='3.1.0'
-pkgrel='3'
+pkgrel='4'
pkgdesc='Abstract engine for text edition in OCaml'
arch=('x86_64' 'i686' 'arm' 'armv6h' 'armv7h' 'aarch64')
url="https://github.com/ocaml-community/$_projectname"
@@ -14,7 +14,7 @@ depends=('ocaml>=4.02.3' 'ocaml-camomile>=1.0.1' 'ocaml-react' 'ocaml-charinfo_w
makedepends=('dune>=1.1.0')
options=('!strip')
source=("$pkgname-$pkgver-$pkgrel.tar.gz::$url/archive/$pkgver.tar.gz")
-sha256sums=('c387b0496c34c7eb680999e751525992e3e636a803297480ef004498887625fd')
+sha512sums=('d4457af15f970adb7b1ed543017e590fa0ecc47171d6dd520a1397f21ce0219caa30a9db7bedb76c0602d4f6d0f0684012cc33feafe18b848d3261a460dea10a')
_sourcedirectory="$_projectname-$pkgver"
@@ -25,11 +25,7 @@ build() {
package() {
cd "$srcdir/$_sourcedirectory/"
- DESTDIR="$pkgdir" dune install --prefix '/usr' --libdir 'lib/ocaml' --release --verbose
-
- install -dm755 "$pkgdir/usr/share/doc/$pkgname"
- mv "$pkgdir/usr/doc/$_projectname/"* "$pkgdir/usr/share/doc/$pkgname/"
- rm -r "$pkgdir/usr/doc/"
+ DESTDIR="$pkgdir" dune install --prefix '/usr' --libdir '/usr/lib/ocaml' --docdir '/usr/share/doc' --mandir '/usr/share/man' --release --verbose
install -dm755 "$pkgdir/usr/share/licenses/$pkgname"
ln -sf "/usr/share/doc/$pkgname/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"