summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJakob Gahde2017-07-16 13:05:24 +0200
committerJakob Gahde2017-07-16 13:06:16 +0200
commitbed3d000472849c2b03e122fe3f9bcef6ff63e10 (patch)
treeaf13c0cdf0823f6a323ed18dca0cae5a5ce438be
parent676ce9f7af53cfce2ef964de9614bff9dff47f95 (diff)
downloadaur-bed3d000472849c2b03e122fe3f9bcef6ff63e10.tar.gz
ocaml-zed 1.4-1: PKGBUILD formatting tweaks
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD31
2 files changed, 18 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a46b76d0a2ae..1a0f77f45d97 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,3 +1,5 @@
+# Generated by mksrcinfo v8
+# Sun Jul 16 11:06:03 UTC 2017
pkgbase = ocaml-zed
pkgdesc = An abstract engine for text editing
pkgver = 1.4
diff --git a/PKGBUILD b/PKGBUILD
index 77d57ee9bb9f..b8d3f96b4924 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,36 +1,37 @@
-# Maintainer: wenLiangcan <boxeed at gmail dot com>
+# Maintainer: Jakob Gahde <j5lx@fmail.co.uk>
+# Contributor: wenLiangcan <boxeed at gmail dot com>
# Contributor: Taylor Venable <taylor@metasyntax.net>
-srcname='zed'
-pkgname="ocaml-${srcname}"
-pkgver='1.4'
+_pkgname='zed'
+pkgname="ocaml-${_pkgname}"
+pkgver=1.4
pkgrel=1
-pkgdesc='An abstract engine for text editing'
+pkgdesc="An abstract engine for text editing"
arch=('i686' 'x86_64')
url='https://github.com/diml/zed'
license=('BSD')
depends=('ocaml' 'ocaml-camomile' 'ocaml-react')
makedepends=('ocaml-findlib')
-source=("https://github.com/diml/zed/archive/${pkgver}.tar.gz")
options=('!strip')
+source=("https://github.com/diml/zed/archive/${pkgver}.tar.gz")
md5sums=('47661250ed1b3e12c886d19c1a019675')
build() {
- cd "$srcdir/${srcname}-${pkgver}"
+ cd "${srcdir}/${_pkgname}-${pkgver}"
./configure
- env DESTDIR="$pkgdir" \
- OCAMLFIND_DESTDIR="$pkgdir/$(ocamlfind printconf destdir)" \
+ env DESTDIR="${pkgdir}" \
+ OCAMLFIND_DESTDIR="${pkgdir}/$(ocamlfind printconf destdir)" \
make
}
package() {
- mkdir -p "$pkgdir/$(ocamlfind printconf destdir)"
- mkdir -p "$pkgdir/$(ocamlfind printconf destdir)/stublibs"
- cd "$srcdir/${srcname}-${pkgver}"
- env DESTDIR="$pkgdir" \
- OCAMLFIND_DESTDIR="$pkgdir/$(ocamlfind printconf destdir)" \
+ mkdir -p "${pkgdir}/$(ocamlfind printconf destdir)"
+ mkdir -p "${pkgdir}/$(ocamlfind printconf destdir)/stublibs"
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ env DESTDIR="${pkgdir}" \
+ OCAMLFIND_DESTDIR="${pkgdir}/$(ocamlfind printconf destdir)" \
make install
- install -Dm 644 LICENSE $pkgdir/usr/share/licenses/$pkgname/LICENSE
+ install -Dm 644 LICENSE ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
}