summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFabioLolix2023-06-18 16:26:22 +0200
committerFabioLolix2023-06-18 16:26:22 +0200
commitf02a78c7061836ec7b9d232027c5d1a934f40491 (patch)
tree03e956fbc368234295268285aaf774d6b2c8070d
downloadaur-f02a78c7061836ec7b9d232027c5d1a934f40491.tar.gz
init
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD41
2 files changed, 64 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e308c2fa0e26
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = ocaml4-lablgtk2
+ pkgdesc = An Objective Caml interface to gtk2
+ pkgver = 2.18.12
+ pkgrel = 1
+ url = https://garrigue.github.io/lablgtk/
+ arch = x86_64
+ license = LGPL2.1
+ makedepends = ocaml4
+ makedepends = ocaml4-compiler-libs
+ makedepends = ocaml4-camlp4
+ makedepends = ocaml4-camlp-streams
+ makedepends = ocaml4-findlib
+ depends = gtk2
+ depends = librsvg
+ optdepends = ocaml4: for using the tools
+ conflicts = lablgtk2
+ options = !makeflags
+ options = staticlibs
+ options = !lto
+ source = lablgtk2-2.18.12.tar.gz::https://github.com/garrigue/lablgtk/archive/2.18.12.tar.gz
+ sha512sums = 284a1234ae817c4df49809d28c103ca5e64046da5ec9ff28c6edc0ce999e9d3e6e180dd053f8b1663d4fb3b7ba19570d53b9441c8fa622add924e8d85e41b813
+
+pkgname = ocaml4-lablgtk2
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ee75a7bafaa6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: Fabio 'Lolix' Loli <fabio.loli@disroot.org> -> https://github.com/FabioLolix
+# Contributor: Juergen Hoetzel <juergen@archlinux.org>
+
+pkgname=ocaml4-lablgtk2
+pkgver=2.18.12
+pkgrel=1
+pkgdesc="An Objective Caml interface to gtk2"
+arch=(x86_64)
+license=(LGPL2.1)
+url="https://garrigue.github.io/lablgtk/"
+depends=(gtk2 librsvg)
+makedepends=(ocaml4 ocaml4-compiler-libs ocaml4-camlp4 ocaml4-camlp-streams ocaml4-findlib)
+optdepends=('ocaml4: for using the tools')
+conflicts=(lablgtk2)
+options=(!makeflags staticlibs !lto)
+source=("lablgtk2-${pkgver}.tar.gz::https://github.com/garrigue/lablgtk/archive/${pkgver}.tar.gz")
+sha512sums=('284a1234ae817c4df49809d28c103ca5e64046da5ec9ff28c6edc0ce999e9d3e6e180dd053f8b1663d4fb3b7ba19570d53b9441c8fa622add924e8d85e41b813')
+
+build() {
+ cd "${srcdir}/lablgtk-${pkgver}"
+ ./configure --prefix=/usr \
+ --without-gnomeui \
+ --without-gnomecanvas \
+ --without-panel \
+ --without-gtkspell \
+ --without-gtksourceview \
+ --without-gtksourceview2 \
+ --without-glade
+ sed -e "s|-O|$CFLAGS|" \
+ -e "s|-shared|& -ccopt \"$LDFLAGS\"|" \
+ -e "s|(CAMLMKLIB)|& -ldopt \"$LDFLAGS\"|" \
+ -i src/Makefile
+ make world
+ make opt
+}
+
+package() {
+ cd "${srcdir}/lablgtk-${pkgver}"
+ make DESTDIR="${pkgdir}" old-install
+ install -m644 META "${pkgdir}/usr/lib/ocaml/lablgtk2/"
+}