summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrew O'Neill2019-12-22 23:19:06 -0500
committerAndrew O'Neill2019-12-22 23:19:06 -0500
commit1a89579143bf6508822b6a15bc1a45ef83e69fb5 (patch)
tree14424cd24cda9b90f9ba0e8d13486d3d38fcea39
parentfa243ddff51a69960e7ae128dde89a80e5daa778 (diff)
downloadaur-1a89579143bf6508822b6a15bc1a45ef83e69fb5.tar.gz
Version bump
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD8
-rw-r--r--oci-cli.patch14
3 files changed, 15 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 158fab8a1ba4..dd38239729b0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = oci-cli
pkgdesc = Command line interface for Oracle Cloud Infrastructure
- pkgver = 2.6.14
+ pkgver = 2.7.0
pkgrel = 1
url = https://github.com/oracle/oci-cli
arch = x86_64
@@ -16,18 +16,16 @@ pkgbase = oci-cli
depends = python-pyopenssl
depends = python-jmespath
depends = python-terminaltables
- depends = python-httpsig_cffi
depends = python-idna
depends = python-pytz
- depends = python-requests
depends = python-six
depends = python-retrying
depends = python-yaml
optdepends = python-cx_oracle-git: Used by the database service
- source = https://github.com/oracle/oci-cli/archive/v2.6.14.tar.gz
+ source = https://github.com/oracle/oci-cli/archive/v2.7.0.tar.gz
source = oci-cli.patch
- sha256sums = 2940c83fe58551d937d1a10c33350141104088896beb1a6253d21fa651e6b141
- sha256sums = 25780c9392fd3f1fa47fe62a4b8171953a8f6fc551664afffd030dae6e0e5cce
+ sha256sums = 582697f77af28134a8a83b35704041be8e5e465980b95d51e25f09600958b6c4
+ sha256sums = 1381e784bff7da6d19d7820c5a0c16a707dfe8d3f290faae7e19539470727d30
pkgname = oci-cli
diff --git a/PKGBUILD b/PKGBUILD
index f31182cbb88a..f47dba631412 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,19 @@
# Maintainer: Andrew O'Neill <andrew at meanjollies dot com>
pkgname=oci-cli
-pkgver=2.6.14
+pkgver=2.7.0
pkgrel=1
pkgdesc='Command line interface for Oracle Cloud Infrastructure'
arch=('x86_64')
url='https://github.com/oracle/oci-cli'
license=('Apache')
-depends=('python' 'python-oci' 'python-arrow' 'python-certifi' 'python-click' 'python-dateutil' 'python-cryptography' 'python-pyopenssl' 'python-jmespath' 'python-terminaltables' 'python-httpsig_cffi' 'python-idna' 'python-pytz' 'python-requests' 'python-six' 'python-retrying' 'python-yaml')
+depends=('python' 'python-oci' 'python-arrow' 'python-certifi' 'python-click' 'python-dateutil' 'python-cryptography' 'python-pyopenssl' 'python-jmespath' 'python-terminaltables' 'python-idna' 'python-pytz' 'python-six' 'python-retrying' 'python-yaml')
makedepends=('python-setuptools')
optdepends=('python-cx_oracle-git: Used by the database service')
source=("${url}/archive/v${pkgver}.tar.gz"
"${pkgname}.patch")
-sha256sums=('2940c83fe58551d937d1a10c33350141104088896beb1a6253d21fa651e6b141'
- '25780c9392fd3f1fa47fe62a4b8171953a8f6fc551664afffd030dae6e0e5cce')
+sha256sums=('582697f77af28134a8a83b35704041be8e5e465980b95d51e25f09600958b6c4'
+ '1381e784bff7da6d19d7820c5a0c16a707dfe8d3f290faae7e19539470727d30')
prepare() {
cd "${pkgname}-${pkgver}"
diff --git a/oci-cli.patch b/oci-cli.patch
index a417b8ab9d04..22d4c5dbce2f 100644
--- a/oci-cli.patch
+++ b/oci-cli.patch
@@ -1,11 +1,11 @@
-diff -rupN oci-cli-2.6.14/setup.py oci-cli-2.6.14b/setup.py
---- oci-cli-2.6.14/setup.py 2019-11-26 20:58:47.000000000 -0500
-+++ oci-cli-2.6.14b/setup.py 2019-11-27 16:56:45.365876010 -0500
+diff -rupN oci-cli-2.7.0/setup.py oci-cli-2.7.0b/setup.py
+--- oci-cli-2.7.0/setup.py 2019-12-17 17:36:23.000000000 -0500
++++ oci-cli-2.7.0b/setup.py 2019-12-22 23:14:43.067307771 -0500
@@ -29,25 +29,24 @@ with open_relative("README.rst") as f:
readme = f.read()
requires = [
-- 'oci==2.7.0',
+- 'oci==2.8.0',
- 'arrow==0.10.0',
+ 'oci',
+ 'arrow',
@@ -41,9 +41,9 @@ diff -rupN oci-cli-2.6.14/setup.py oci-cli-2.6.14b/setup.py
}
fips_libcrypto_file = os.getenv("OCI_CLI_FIPS_LIBCRYPTO_FILE")
-diff -rupN oci-cli-2.6.14/src/oci_cli/cli_root.py oci-cli-2.6.14b/src/oci_cli/cli_root.py
---- oci-cli-2.6.14/src/oci_cli/cli_root.py 2019-11-26 20:58:47.000000000 -0500
-+++ oci-cli-2.6.14b/src/oci_cli/cli_root.py 2019-11-27 16:57:51.952429267 -0500
+diff -rupN oci-cli-2.7.0/src/oci_cli/cli_root.py oci-cli-2.7.0b/src/oci_cli/cli_root.py
+--- oci-cli-2.7.0/src/oci_cli/cli_root.py 2019-12-17 17:36:23.000000000 -0500
++++ oci-cli-2.7.0b/src/oci_cli/cli_root.py 2019-12-22 23:15:30.747147899 -0500
@@ -219,7 +219,7 @@ For information on configuration, see ht
@click.option('--profile',
default=Sentinel(DEFAULT_PROFILE), show_default=False,