summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrew O'Neill2018-08-14 20:47:40 -0400
committerAndrew O'Neill2018-08-14 20:47:40 -0400
commit7ba955f3e766f2b4b45d66655b9f1531abdd14d0 (patch)
tree248708b7514a4f6f78713dae2a9a988fbee6e91b
parent161104daf5fe82cb04101dd61c923b1205f0285c (diff)
downloadaur-7ba955f3e766f2b4b45d66655b9f1531abdd14d0.tar.gz
Version bump
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD6
-rw-r--r--oci-cli.patch16
3 files changed, 14 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 94a50c975915..499158baad26 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = oci-cli
pkgdesc = Command line interface for Oracle Cloud Infrastructure
- pkgver = 2.4.29
+ pkgver = 2.4.30
pkgrel = 1
url = https://github.com/oracle/oci-cli
arch = any
@@ -22,10 +22,10 @@ pkgbase = oci-cli
depends = python-requests
depends = python-six
depends = python-retrying
- source = https://github.com/oracle/oci-cli/archive/v2.4.29.tar.gz
+ source = https://github.com/oracle/oci-cli/archive/v2.4.30.tar.gz
source = oci-cli.patch
- sha256sums = c593fc7810193b343b9291bc37e3e5295ca10a2e117e6916a8f61b3b76e3f067
- sha256sums = a54477bbd655a0b07c7092ddbd19bfa7b3e6cc09d450a87b82c55c19ff432495
+ sha256sums = 97c1fe5efe4985af23bcd917cfec9509f373d276835a56cfc73e74ce5df3a151
+ sha256sums = 5e5537d41f4e7261e5fb1f6a47ddcc7ba79b58973048c932c2fba3ad85f261e2
pkgname = oci-cli
diff --git a/PKGBUILD b/PKGBUILD
index ce362c45cabf..cac552dda7dc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Andrew O'Neill <andrew at meanjollies dot com>
pkgname=oci-cli
-pkgver=2.4.29
+pkgver=2.4.30
pkgrel=1
pkgdesc='Command line interface for Oracle Cloud Infrastructure'
arch=('any')
@@ -11,8 +11,8 @@ depends=('python' 'python-oci' 'python-arrow' 'python-certifi' 'python-click' 'p
makedepends=('python-setuptools')
source=("${url}/archive/v${pkgver}.tar.gz"
"${pkgname}.patch")
-sha256sums=('c593fc7810193b343b9291bc37e3e5295ca10a2e117e6916a8f61b3b76e3f067'
- 'a54477bbd655a0b07c7092ddbd19bfa7b3e6cc09d450a87b82c55c19ff432495')
+sha256sums=('97c1fe5efe4985af23bcd917cfec9509f373d276835a56cfc73e74ce5df3a151'
+ '5e5537d41f4e7261e5fb1f6a47ddcc7ba79b58973048c932c2fba3ad85f261e2')
prepare() {
cd "${pkgname}-${pkgver}"
diff --git a/oci-cli.patch b/oci-cli.patch
index 06b02f1393ff..163400b8ea68 100644
--- a/oci-cli.patch
+++ b/oci-cli.patch
@@ -1,11 +1,11 @@
-diff -rupN oci-cli-2.4.29/setup.py oci-cli-2.4.29b/setup.py
---- oci-cli-2.4.29/setup.py 2018-07-26 20:59:08.000000000 -0400
-+++ oci-cli-2.4.29b/setup.py 2018-07-27 23:11:43.325799289 -0400
-@@ -30,21 +30,20 @@ with open_relative("README.rst") as f:
-
+diff -rupN oci-cli-2.4.30/setup.py oci-cli-2.4.30b/setup.py
+--- oci-cli-2.4.30/setup.py 2018-08-09 18:34:30.000000000 -0400
++++ oci-cli-2.4.30b/setup.py 2018-08-14 20:30:59.057305283 -0400
+@@ -28,20 +28,19 @@ with open_relative("README.rst") as f:
+ readme = f.read()
requires = [
-- 'oci==2.0.0',
+- 'oci==2.0.1',
- 'arrow==0.10.0',
+ 'oci',
+ 'arrow',
@@ -13,7 +13,6 @@ diff -rupN oci-cli-2.4.29/setup.py oci-cli-2.4.29b/setup.py
- 'click==6.7',
- 'configparser==3.5.0',
- 'cryptography==2.1.3',
-- 'pyOpenSSL<=17.4.0',
- 'httpsig_cffi==15.0.0',
- 'jmespath==0.9.3',
- 'python-dateutil==2.7.3',
@@ -24,7 +23,6 @@ diff -rupN oci-cli-2.4.29/setup.py oci-cli-2.4.29b/setup.py
- 'idna>=2.5,<2.7'
+ 'click',
+ 'cryptography',
-+ 'pyOpenSSL',
+ 'httpsig_cffi',
+ 'jmespath',
+ 'python-dateutil',
@@ -35,4 +33,4 @@ diff -rupN oci-cli-2.4.29/setup.py oci-cli-2.4.29b/setup.py
+ 'idna'
]
- setup(
+ fips_libcrypto_file = os.getenv("OCI_CLI_FIPS_LIBCRYPTO_FILE")