summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrew O'Neill2020-09-02 20:01:49 -0400
committerAndrew O'Neill2020-09-02 20:01:49 -0400
commit872b06b22417dbb2e40c92003db386c3c70d41de (patch)
tree8581aff25a714e0a6c20987ad1415eb4ecdbde2c
parent2cddbd8d9680bc9a64381fc49b0a8cf2d7480e62 (diff)
downloadaur-872b06b22417dbb2e40c92003db386c3c70d41de.tar.gz
Version bump
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD6
-rw-r--r--oci-cli.patch18
3 files changed, 16 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bb0a3d57eefc..52c0381a362f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = oci-cli
pkgdesc = Command line interface for Oracle Cloud Infrastructure
- pkgver = 2.12.8
+ pkgver = 2.12.9
pkgrel = 1
url = https://github.com/oracle/oci-cli
arch = x86_64
@@ -22,10 +22,10 @@ pkgbase = oci-cli
depends = python-retrying
depends = python-yaml
optdepends = python-cx_oracle-git: Used by the database service
- source = oci-cli-2.12.8.tar.gz::https://github.com/oracle/oci-cli/archive/v2.12.8.tar.gz
+ source = oci-cli-2.12.9.tar.gz::https://github.com/oracle/oci-cli/archive/v2.12.9.tar.gz
source = oci-cli.patch
- sha256sums = c15832ecf35222650183ec239d2664f776c7f5d830e4dc280569f6cc2f332ed7
- sha256sums = e1db49e195ff6628a7912acabdbc53c942df59977b55d28b16efcc27474a46fd
+ sha256sums = f1fa5c35ac273532edc772733786cae2d4a6b3517dfcb0cebea2ce1186b91d84
+ sha256sums = 0f34a3fc511fad1026ce15490e819dec07f5b50de6f506768d7336d94747f946
pkgname = oci-cli
diff --git a/PKGBUILD b/PKGBUILD
index e9fc5610bfc3..e85ad6fc03db 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Andrew O'Neill <andrew at meanjollies dot com>
pkgname=oci-cli
-pkgver=2.12.8
+pkgver=2.12.9
pkgrel=1
pkgdesc='Command line interface for Oracle Cloud Infrastructure'
arch=('x86_64')
@@ -12,8 +12,8 @@ makedepends=('python-setuptools')
optdepends=('python-cx_oracle-git: Used by the database service')
source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz"
"${pkgname}.patch")
-sha256sums=('c15832ecf35222650183ec239d2664f776c7f5d830e4dc280569f6cc2f332ed7'
- 'e1db49e195ff6628a7912acabdbc53c942df59977b55d28b16efcc27474a46fd')
+sha256sums=('f1fa5c35ac273532edc772733786cae2d4a6b3517dfcb0cebea2ce1186b91d84'
+ '0f34a3fc511fad1026ce15490e819dec07f5b50de6f506768d7336d94747f946')
prepare() {
cd "${pkgname}-${pkgver}"
diff --git a/oci-cli.patch b/oci-cli.patch
index 8fbbf001fd8c..918ff6ed0526 100644
--- a/oci-cli.patch
+++ b/oci-cli.patch
@@ -1,11 +1,11 @@
-diff -rupN oci-cli-2.12.8/setup.py oci-cli-2.12.8b/setup.py
---- oci-cli-2.12.8/setup.py 2020-08-18 17:16:33.000000000 -0400
-+++ oci-cli-2.12.8b/setup.py 2020-08-20 19:22:37.686632968 -0400
+diff -rupN oci-cli-2.12.9/setup.py oci-cli-2.12.9b/setup.py
+--- oci-cli-2.12.9/setup.py 2020-09-01 14:44:10.000000000 -0400
++++ oci-cli-2.12.9b/setup.py 2020-09-02 19:54:13.527968891 -0400
@@ -30,24 +30,23 @@ with open_relative("README.rst") as f:
readme = f.read()
requires = [
-- 'oci==2.21.1',
+- 'oci==2.21.2',
- 'arrow==0.14.7',
+ 'oci',
+ 'arrow',
@@ -13,7 +13,7 @@ diff -rupN oci-cli-2.12.8/setup.py oci-cli-2.12.8b/setup.py
- 'click==6.7',
- 'configparser==4.0.2',
- 'cryptography==2.8',
-- 'jmespath==0.9.4',
+- 'jmespath==0.10.0',
- 'python-dateutil>=2.5.3,<3.0.0',
- 'pytz>=2016.10',
- 'retrying==1.3.3',
@@ -39,10 +39,10 @@ diff -rupN oci-cli-2.12.8/setup.py oci-cli-2.12.8b/setup.py
}
fips_libcrypto_file = os.getenv("OCI_CLI_FIPS_LIBCRYPTO_FILE")
-diff -rupN oci-cli-2.12.8/src/oci_cli/cli_root.py oci-cli-2.12.8b/src/oci_cli/cli_root.py
---- oci-cli-2.12.8/src/oci_cli/cli_root.py 2020-08-18 17:16:33.000000000 -0400
-+++ oci-cli-2.12.8b/src/oci_cli/cli_root.py 2020-08-20 19:23:38.206807707 -0400
-@@ -218,7 +218,7 @@ For information on configuration, see ht
+diff -rupN oci-cli-2.12.9/src/oci_cli/cli_root.py oci-cli-2.12.9b/src/oci_cli/cli_root.py
+--- oci-cli-2.12.9/src/oci_cli/cli_root.py 2020-09-01 14:44:10.000000000 -0400
++++ oci-cli-2.12.9b/src/oci_cli/cli_root.py 2020-09-02 19:55:23.467781552 -0400
+@@ -297,7 +297,7 @@ For information on configuration, see ht
@click.option('--profile',
default=Sentinel(DEFAULT_PROFILE), show_default=False,
help='The profile in the config file to load. This profile will also be used to locate any default parameter values which have been specified in the OCI CLI-specific configuration file. [default: DEFAULT]')