summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrew O'Neill2019-03-15 23:51:00 -0400
committerAndrew O'Neill2019-03-15 23:51:00 -0400
commitfed8918be1424d4ac058c993be5dbe7ead0e1d6e (patch)
tree4041fa98d030998de06b992a5c7c889d88b383e5
parentcbdd2969ac28d4bf45f4bd168898c91dabe128a7 (diff)
downloadaur-fed8918be1424d4ac058c993be5dbe7ead0e1d6e.tar.gz
Version bump
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD8
-rw-r--r--oci-cli.patch34
3 files changed, 36 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5a0d8381e2ed..20295ac8578d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = oci-cli
pkgdesc = Command line interface for Oracle Cloud Infrastructure
- pkgver = 2.4.33
+ pkgver = 2.5.3
pkgrel = 1
url = https://github.com/oracle/oci-cli
arch = any
@@ -22,10 +22,12 @@ pkgbase = oci-cli
depends = python-requests
depends = python-six
depends = python-retrying
- source = https://github.com/oracle/oci-cli/archive/v2.4.33.tar.gz
+ depends = python-yaml
+ depends = python-cx_oracle-git
+ source = https://github.com/oracle/oci-cli/archive/v2.5.3.tar.gz
source = oci-cli.patch
- sha256sums = f8ead61b820d1ac814285db9c522ffab62cbc556d1c1208ef7e1424306714f2d
- sha256sums = b77e6f8fec8b2960e50063771e3fcaaa157ccaab0ddea0b4df817afbd052ab54
+ sha256sums = 379de4d8891004edf22313d5bb9ef0dd183405ae16a48001cfdb3b3d9329dca5
+ sha256sums = 302c4878f786518cb0589187f73f82e2a66eaeba1107c8486f920c4bd1f2bb43
pkgname = oci-cli
diff --git a/PKGBUILD b/PKGBUILD
index 4147a2aec0a7..6c78aa76373c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,18 @@
# Maintainer: Andrew O'Neill <andrew at meanjollies dot com>
pkgname=oci-cli
-pkgver=2.4.33
+pkgver=2.5.3
pkgrel=1
pkgdesc='Command line interface for Oracle Cloud Infrastructure'
arch=('any')
url='https://github.com/oracle/oci-cli'
license=('Apache')
-depends=('python' 'python-oci' 'python-arrow' 'python-certifi' 'python-click' 'python-dateutil' 'python-cryptography' 'python-pyopenssl' 'python-jmespath' 'python-terminaltables' 'python-httpsig_cffi' 'python-idna' 'python-pytz' 'python-requests' 'python-six' 'python-retrying')
+depends=('python' 'python-oci' 'python-arrow' 'python-certifi' 'python-click' 'python-dateutil' 'python-cryptography' 'python-pyopenssl' 'python-jmespath' 'python-terminaltables' 'python-httpsig_cffi' 'python-idna' 'python-pytz' 'python-requests' 'python-six' 'python-retrying' 'python-yaml' 'python-cx_oracle-git')
makedepends=('python-setuptools')
source=("${url}/archive/v${pkgver}.tar.gz"
"${pkgname}.patch")
-sha256sums=('f8ead61b820d1ac814285db9c522ffab62cbc556d1c1208ef7e1424306714f2d'
- 'b77e6f8fec8b2960e50063771e3fcaaa157ccaab0ddea0b4df817afbd052ab54')
+sha256sums=('379de4d8891004edf22313d5bb9ef0dd183405ae16a48001cfdb3b3d9329dca5'
+ '302c4878f786518cb0589187f73f82e2a66eaeba1107c8486f920c4bd1f2bb43')
prepare() {
cd "${pkgname}-${pkgver}"
diff --git a/oci-cli.patch b/oci-cli.patch
index 98f8f9826bfd..4fce26150e92 100644
--- a/oci-cli.patch
+++ b/oci-cli.patch
@@ -1,18 +1,19 @@
-diff -rupN oci-cli-2.4.33/setup.py oci-cli-2.4.33b/setup.py
---- oci-cli-2.4.33/setup.py 2018-09-27 16:18:40.000000000 -0400
-+++ oci-cli-2.4.33b/setup.py 2018-09-30 14:14:19.094669289 -0400
-@@ -28,20 +28,19 @@ with open_relative("README.rst") as f:
+diff -rupN oci-cli-2.5.3/setup.py oci-cli-2.5.3b/setup.py
+--- oci-cli-2.5.3/setup.py 2019-03-12 14:02:50.000000000 -0400
++++ oci-cli-2.5.3b/setup.py 2019-03-15 23:21:14.762363410 -0400
+@@ -29,23 +29,22 @@ with open_relative("README.rst") as f:
readme = f.read()
requires = [
-- 'oci==2.0.4',
+- 'oci==2.2.2',
- 'arrow==0.10.0',
+ 'oci',
+ 'arrow',
'certifi',
- 'click==6.7',
- 'configparser==3.5.0',
-- 'cryptography==2.1.3',
+- 'cryptography==2.4.2',
+- 'cx_Oracle==7.0',
- 'httpsig_cffi==15.0.0',
- 'jmespath==0.9.3',
- 'python-dateutil==2.7.3',
@@ -20,9 +21,12 @@ diff -rupN oci-cli-2.4.33/setup.py oci-cli-2.4.33b/setup.py
- 'retrying==1.3.3',
- 'six==1.11.0',
- 'terminaltables==3.1.0',
-- 'idna>=2.5,<2.7'
+- 'idna>=2.5,<2.7',
+- 'pyOpenSSL==18.0.0',
+- 'PyYAML==3.13'
+ 'click',
+ 'cryptography',
++ 'cx_Oracle',
+ 'httpsig_cffi',
+ 'jmespath',
+ 'python-dateutil',
@@ -30,7 +34,21 @@ diff -rupN oci-cli-2.4.33/setup.py oci-cli-2.4.33b/setup.py
+ 'retrying',
+ 'six',
+ 'terminaltables',
-+ 'idna'
++ 'idna',
++ 'pyOpenSSL',
++ 'PyYAML'
]
fips_libcrypto_file = os.getenv("OCI_CLI_FIPS_LIBCRYPTO_FILE")
+diff -rupN oci-cli-2.5.3/src/oci_cli/cli_root.py oci-cli-2.5.3b/src/oci_cli/cli_root.py
+--- oci-cli-2.5.3/src/oci_cli/cli_root.py 2019-03-12 14:02:50.000000000 -0400
++++ oci-cli-2.5.3b/src/oci_cli/cli_root.py 2019-03-15 23:22:26.492727407 -0400
+@@ -197,7 +197,7 @@ For information on configuration, see ht
+ @click.option('--profile',
+ default=Sentinel(DEFAULT_PROFILE), show_default=False,
+ help='The profile in the config file to load. This profile will also be used to locate any default parameter values which have been specified in the OCI CLI-specific configuration file. [default: DEFAULT]')
+-@click.option('--cli-rc-file', '--defaults-file',
++@click.option('--cli-rc-file', '--defaults-file', 'defaults_file',
+ default=cli_constants.CLI_RC_DEFAULT_LOCATION, show_default=True,
+ is_eager=True, callback=eager_load_cli_rc_file,
+ help='The path to the OCI CLI-specific configuration file, containing parameter default values and other configuration information such as command aliases and predefined queries. The --defaults-file option is deprecated and you should use the --cli-rc-file option instead.')