summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMikael Eriksson2021-06-24 09:28:59 +0200
committerMikael Eriksson2021-06-24 09:28:59 +0200
commit17d5377fb7c8cbebc760b26889026c1026ca5b2a (patch)
treeca704eaa503b74e9e54cb6ab2d05d6b5250f8f58
parent7f3d64e2ef28eb52ed1ecc5805cffc60a798c534 (diff)
downloadaur-17d5377fb7c8cbebc760b26889026c1026ca5b2a.tar.gz
0.2.90-1
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD29
-rw-r--r--fix-unifont.diff37
3 files changed, 56 insertions, 23 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 23c8d70d94f5..20fbbffcc550 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = ocp
pkgdesc = Open Cubic Player
- pkgver = 0.2.2
+ pkgver = 0.2.90
pkgrel = 1
url = https://github.com/mywave82/opencubicplayer
arch = i686
@@ -22,14 +22,17 @@ pkgbase = ocp
depends = libpng
depends = freetype2
depends = ttf-unifont
- source = git+https://github.com/mywave82/opencubicplayer.git#tag=v0.2.2
+ source = git+https://github.com/mywave82/opencubicplayer.git#tag=v0.2.90
source = git+https://github.com/mywave82/timidity.git
- source = git+https://github.com/mywave82/sidplay-residfp-ocp
+ source = git+https://github.com/mywave82/sidplay-residfp-ocp.git
+ source = git+https://github.com/libsidplayfp/exsid-driver.git
+ source = git+https://github.com/mywave82/resid.git
source = fix-unifont.diff
md5sums = SKIP
md5sums = SKIP
md5sums = SKIP
- md5sums = 98a6ab1b11da171b118e0cf7b0485e7c
+ md5sums = SKIP
+ md5sums = SKIP
+ md5sums = 9eb83ffbabec3f1dd66f66c9100a9c08
pkgname = ocp
-
diff --git a/PKGBUILD b/PKGBUILD
index c9e81ab7a189..f55f4a88bf6d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Original PKGBUILD by: berkus [berkus_at_madfire_dot_net]
pkgname=ocp
-pkgver=0.2.2
+pkgver=0.2.90
pkgrel=1
pkgdesc="Open Cubic Player"
arch=('i686' 'x86_64')
@@ -12,30 +12,43 @@ makedepends=('desktop-file-utils' 'git' 'xa' 'patch')
license=('GPL')
source=(git+https://github.com/mywave82/opencubicplayer.git#tag=v${pkgver}
git+https://github.com/mywave82/timidity.git
- git+https://github.com/mywave82/sidplay-residfp-ocp
+ git+https://github.com/mywave82/sidplay-residfp-ocp.git
+ git+https://github.com/libsidplayfp/exsid-driver.git
+ git+https://github.com/mywave82/resid.git
fix-unifont.diff)
md5sums=('SKIP'
'SKIP'
'SKIP'
- '98a6ab1b11da171b118e0cf7b0485e7c')
+ 'SKIP'
+ 'SKIP'
+ '9eb83ffbabec3f1dd66f66c9100a9c08')
prepare() {
cd opencubicplayer
+
+ patch -p1 -i "$srcdir/fix-unifont.diff"
+
+ git submodule init
+ git config submodule.playgmi/timidity-git.url "$srcdir/timidity"
+ git config submodule.playsid/sidplayfp-git.url "$srcdir/sidplay-residfp-ocp"
+ git submodule update
+
+ cd playsid/libsidplayfp-git
+
git submodule init
- git config submodule.playgmi/timidity-git.url $srcdir/timidity
- git config submodule.playsid/sidplayfp-git.url $srcdir/sidplay-residfp-ocp
+ git config submodule.src/builders/exsid-builder/driver.url "$srcdir/exsid-driver"
+ git config submodule.src/builders/resid-builder/resid.url "$srcdir/resid"
git submodule update
}
build() {
cd opencubicplayer
- patch -p1 -i $srcdir/fix-unifont.diff
./configure --prefix=/usr --sysconfdir=/etc --with-unifontdir=/usr/share/fonts/Unifont
- make DESTDIR=$pkgdir
+ make DESTDIR="$pkgdir"
}
package() {
cd opencubicplayer
- make DESTDIR=$pkgdir install
+ make DESTDIR="$pkgdir" install
}
diff --git a/fix-unifont.diff b/fix-unifont.diff
index 676bb73b5c2c..7fdc8c652186 100644
--- a/fix-unifont.diff
+++ b/fix-unifont.diff
@@ -2,7 +2,7 @@ Index: asdf/configure
===================================================================
--- asdf.orig/configure
+++ asdf/configure
-@@ -9849,15 +9849,15 @@ fi
+@@ -9916,15 +9916,15 @@ fi
prefix=$prefix_save
exec_prefix=$exec_prefix_save
@@ -22,12 +22,12 @@ Index: asdf/configure
eval "$as_ac_File=yes"
else
eval "$as_ac_File=no"
-@@ -9869,18 +9869,18 @@ $as_echo "$ac_res" >&6; }
+@@ -9936,18 +9936,18 @@ $as_echo "$ac_res" >&6; }
if eval test \"x\$"$as_ac_File"\" = x"yes"; then :
else
-- as_fn_error $? "$UNIFONTDIR/unifont.ttf not found - please use --with-unifontdir=/path/ (needed by SDL2)" "$LINENO" 5
-+ as_fn_error $? "$UNIFONTDIR/Unifont.ttf not found - please use --with-unifontdir=/path/ (needed by SDL2)" "$LINENO" 5
+- as_fn_error $? "$UNIFONTDIR/unifont.ttf not found - please use --with-unifontdir=/path/ (needed by X11, SDL1.x and SDL2)" "$LINENO" 5
++ as_fn_error $? "$UNIFONTDIR/Unifont.ttf not found - please use --with-unifontdir=/path/ (needed by X11, SDL1.x and SDL2)" "$LINENO" 5
fi
- as_ac_File=`$as_echo "ac_cv_file_$UNIFONTDIR/unifont_csur.ttf" | $as_tr_sh`
@@ -46,12 +46,12 @@ Index: asdf/configure
eval "$as_ac_File=yes"
else
eval "$as_ac_File=no"
-@@ -9892,18 +9892,18 @@ $as_echo "$ac_res" >&6; }
+@@ -9959,18 +9959,18 @@ $as_echo "$ac_res" >&6; }
if eval test \"x\$"$as_ac_File"\" = x"yes"; then :
else
-- as_fn_error $? "$UNIFONTDIR/unifont_csur.ttf not found - please use --with-unifontdir=/path/ (needed by SDL2)" "$LINENO" 5
-+ as_fn_error $? "$UNIFONTDIR/Unifont_CSUR.ttf not found - please use --with-unifontdir=/path/ (needed by SDL2)" "$LINENO" 5
+- as_fn_error $? "$UNIFONTDIR/unifont_csur.ttf not found - please use --with-unifontdir=/path/ (needed by X11, SDL1.x and SDL2)" "$LINENO" 5
++ as_fn_error $? "$UNIFONTDIR/Unifont_CSUR.ttf not found - please use --with-unifontdir=/path/ (needed by X11, SDL1.x and SDL2)" "$LINENO" 5
fi
- as_ac_File=`$as_echo "ac_cv_file_$UNIFONTDIR/unifont_upper.ttf" | $as_tr_sh`
@@ -70,15 +70,32 @@ Index: asdf/configure
eval "$as_ac_File=yes"
else
eval "$as_ac_File=no"
-@@ -9915,7 +9915,7 @@ $as_echo "$ac_res" >&6; }
+@@ -9982,7 +9982,7 @@ $as_echo "$ac_res" >&6; }
if eval test \"x\$"$as_ac_File"\" = x"yes"; then :
else
-- as_fn_error $? "$UNIFONTDIR/unifont_upper.ttf not found - please use --with-unifontdir=/path/ (needed by SDL2)" "$LINENO" 5
-+ as_fn_error $? "$UNIFONTDIR/Unifont_Upper.ttf not found - please use --with-unifontdir=/path/ (needed by SDL2)" "$LINENO" 5
+- as_fn_error $? "$UNIFONTDIR/unifont_upper.ttf not found - please use --with-unifontdir=/path/ (needed by X11, SDL1.x and SDL2)" "$LINENO" 5
++ as_fn_error $? "$UNIFONTDIR/Unifont_Upper.ttf not found - please use --with-unifontdir=/path/ (needed by X11, SDL1.x and SDL2)" "$LINENO" 5
fi
cat >>confdefs.h <<_ACEOF
+Index: asdf/configure.ac
+===================================================================
+--- asdf.orig/configure.ac
++++ asdf/configure.ac
+@@ -582,9 +582,9 @@ if test "x$HAVE_SDL" = "x1" || test "x$H
+
+ dnl locate the ttf-unifont
+ AS_AC_EXPAND(UNIFONTDIR, $with_unifontdir)
+- AC_CHECK_FILE($UNIFONTDIR/unifont.ttf, , AC_MSG_ERROR([$UNIFONTDIR/unifont.ttf not found - please use --with-unifontdir=/path/ (needed by X11, SDL1.x and SDL2)]))
+- AC_CHECK_FILE($UNIFONTDIR/unifont_csur.ttf, , AC_MSG_ERROR([$UNIFONTDIR/unifont_csur.ttf not found - please use --with-unifontdir=/path/ (needed by X11, SDL1.x and SDL2)]))
+- AC_CHECK_FILE($UNIFONTDIR/unifont_upper.ttf, , AC_MSG_ERROR([$UNIFONTDIR/unifont_upper.ttf not found - please use --with-unifontdir=/path/ (needed by X11, SDL1.x and SDL2)]))
++ AC_CHECK_FILE($UNIFONTDIR/Unifont.ttf, , AC_MSG_ERROR([$UNIFONTDIR/Unifont.ttf not found - please use --with-unifontdir=/path/ (needed by X11, SDL1.x and SDL2)]))
++ AC_CHECK_FILE($UNIFONTDIR/Unifont_CSUR.ttf, , AC_MSG_ERROR([$UNIFONTDIR/Unifont_CSUR.ttf not found - please use --with-unifontdir=/path/ (needed by X11, SDL1.x and SDL2)]))
++ AC_CHECK_FILE($UNIFONTDIR/Unifont_Upper.ttf, , AC_MSG_ERROR([$UNIFONTDIR/Unifont_Upper.ttf not found - please use --with-unifontdir=/path/ (needed by X11, SDL1.x and SDL2)]))
+ AC_DEFINE_UNQUOTED(UNIFONTDIR, "$UNIFONTDIR")
+ fi
+
Index: asdf/stuff/poutput-fontengine.c
===================================================================
--- asdf.orig/stuff/poutput-fontengine.c