summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorXavier2023-02-05 20:56:45 -0500
committerXavier2023-02-05 20:56:45 -0500
commit6b083f1206eee1782037c08899f894c08262010a (patch)
tree29968f6a344ad8a0372be12b52d98bd2c7bc8aa7
parentc683366bb71c848446b41d8c27ac1cbb5266bd92 (diff)
downloadaur-6b083f1206eee1782037c08899f894c08262010a.tar.gz
Package release bump with the addition of the libancient, and
shared-mime-info dependencies.
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD11
2 files changed, 10 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8bb9d8254809..dc5459d4f81b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = ocp
pkgdesc = Open Cubic Player
pkgver = 0.2.102
- pkgrel = 1
+ pkgrel = 2
url = https://stian.cubic.org/project-ocp.php
install = ocp.install
arch = i686
@@ -24,6 +24,8 @@ pkgbase = ocp
depends = ttf-unifont
depends = libdiscid
depends = cjson
+ depends = shared-mime-info
+ depends = libancient
provides = ocp=0.2.102
conflicts = ocp-git
source = ocp::git+https://github.com/mywave82/opencubicplayer.git#tag=v0.2.102
diff --git a/PKGBUILD b/PKGBUILD
index 43746ca8c39c..050240825c66 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
_pkgbase=ocp
pkgname=${_pkgbase}
pkgver=0.2.102
-pkgrel=1
+pkgrel=2
pkgdesc="Open Cubic Player"
arch=('i686' 'x86_64')
url="https://stian.cubic.org/project-ocp.php"
@@ -28,7 +28,9 @@ depends=('hicolor-icon-theme'
'freetype2'
'ttf-unifont'
'libdiscid'
- 'cjson')
+ 'cjson'
+ 'shared-mime-info'
+ 'libancient')
makedepends=('git'
'xa'
@@ -40,12 +42,13 @@ md5sums=('SKIP')
prepare() {
cd $_pkgbase
git submodule init
- git submodule update --init --recursive
+ git submodule update --init --recursive
+ git merge 006541750261fe6b0a06a1792170719cca09d548
}
build() {
cd $_pkgbase
- ./configure --prefix=/usr --sysconfdir=/etc --with-unifontdir=/usr/share/fonts/Unifont --with-unifont-ttf=/usr/share/fonts/Unifont/Unifont.ttf --with-unifont-csur-ttf=/usr/share/fonts/Unifont/Unifont_CSUR.ttf --with-unifont-upper-ttf=/usr/share/fonts/Unifont/Unifont_Upper.ttf
+ ./configure --prefix=/usr --sysconfdir=/etc --without-update-desktop-database --without-update-mime-database --with-unifontdir=/usr/share/fonts/Unifont --with-unifont-ttf=/usr/share/fonts/Unifont/Unifont.ttf --with-unifont-csur-ttf=/usr/share/fonts/Unifont/Unifont_CSUR.ttf --with-unifont-upper-ttf=/usr/share/fonts/Unifont/Unifont_Upper.ttf
make DESTDIR="$pkgdir"
}