summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorXavier2023-02-18 08:27:30 -0500
committerXavier2023-02-18 08:27:30 -0500
commit107b2b6c599d88501b377119d4612008768f2255 (patch)
treeebeaec51a1f65bb2d3ae0f7b6b159abd26902e5e
parent9c864eba92e205fa74d8ce9e2ee9a73797bf6bf4 (diff)
downloadaur-107b2b6c599d88501b377119d4612008768f2255.tar.gz
Bump to release 2 clarifying dependency semantics
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD22
2 files changed, 23 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b135e7f847f7..d9bdbe5e573f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,20 @@
pkgbase = ocp-git
pkgdesc = Open Cubic Player (GIT Version)
pkgver = 0.2.102.r25.be056b7
- pkgrel = 1
+ pkgrel = 2
url = https://stian.cubic.org/project-ocp.php
arch = i686
arch = x86_64
license = GPL
- makedepends = git
- makedepends = xa
+ makedepends = alsa-libs
+ makedepends = cjson
makedepends = desktop-file-utils
- makedepends = alsa-lib
- makedepends = sdl2
makedepends = freetype2
makedepends = flac
- makedepends = cjson
+ makedepends = git
+ makedepends = ncurses
+ makedepends = sdl2
+ makedepends = xa
makedepends = libancient
makedepends = libdiscid
makedepends = libmad
@@ -30,6 +31,7 @@ pkgbase = ocp-git
pkgname = ocp-git
depends = alsa-lib
depends = cjson
+ depends = ncurses
depends = libancient
depends = libdiscid
provides = ocp=0.2.102.r25.be056b7
@@ -43,12 +45,14 @@ pkgname = ocp-sdl2-git
depends = cjson
depends = freetype2
depends = hicolor-icon-theme
+ depends = ncurses
depends = sdl2
depends = shared-mime-info
depends = libancient
depends = libdiscid
depends = libjpeg-turbo
depends = libpng
+ depends = ttf-unifont
provides = ocp-sdl2=0.2.102.r25.be056b7
conflicts = ocp
conflicts = ocp-curses
diff --git a/PKGBUILD b/PKGBUILD
index 1c87fa0ba22f..ffd712a8edc0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
_pkgbase=ocp
pkgname=('ocp-git' 'ocp-sdl2-git')
pkgver=0.2.102.r25.be056b7
-pkgrel=1
+pkgrel=2
pkgdesc="Open Cubic Player (GIT Version)"
arch=('i686' 'x86_64')
url="https://stian.cubic.org/project-ocp.php"
@@ -14,14 +14,15 @@ optdepends=('libvorbis: Vorbis codec support'
'libmad: MPEG codec support'
'flac: FLAC codec support')
-makedepends=('git'
- 'xa'
+makedepends=('alsa-libs'
+ 'cjson'
'desktop-file-utils'
- 'alsa-lib'
- 'sdl2'
- 'freetype2'
+ 'freetype2'
'flac'
- 'cjson'
+ 'git'
+ 'ncurses'
+ 'sdl2'
+ 'xa'
'libancient'
'libdiscid'
'libmad'
@@ -70,12 +71,14 @@ package_ocp-sdl2-git() {
'cjson'
'freetype2'
'hicolor-icon-theme'
+ 'ncurses'
'sdl2'
'shared-mime-info'
'libancient'
'libdiscid'
'libjpeg-turbo'
- 'libpng')
+ 'libpng'
+ 'ttf-unifont')
cd $_pkgbase
./configure --prefix=/usr --sysconfdir=/etc --with-builtin=core\
--without-update-desktop-database\
@@ -94,10 +97,11 @@ package_ocp-git() {
conflicts=('ocp-curses' 'ocp-sdl2')
depends=('alsa-lib'
'cjson'
+ 'ncurses'
'libancient'
'libdiscid')
cd $_pkgbase
- ./configure --prefix=/usr --sysconfdir=/etc --with-builtin=core\
+ ./configure --prefix=/usr --sysconfdir=/etc --with-builtin=core\
--without-x11 --without-sdl2\
--without-update-desktop-database\
--without-update-mime-database