summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorXavier Moffett2024-10-11 18:01:16 -0400
committerXavier Moffett2024-10-11 18:03:47 -0400
commit15c64ddd575ce4a2879ce78fc9e30e808e9906ed (patch)
treefabac43e96e1322206b7e4067266a0de40a9f87d
parentfa932f38a8b32cbfdb25b084dcda37022938c90f (diff)
downloadaur-15c64ddd575ce4a2879ce78fc9e30e808e9906ed.tar.gz
Formatting
-rw-r--r--PKGBUILD144
1 files changed, 72 insertions, 72 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e0335289ad5e..6dd6447d82af 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -14,94 +14,94 @@ source=(${_pkgbase}::git+https://github.com/mywave82/opencubicplayer.git)
sha256sums=('SKIP')
optdepends=('libvorbis: Vorbis codec support'
- 'libmad: MPEG codec support'
- 'flac: FLAC codec support'
- 'libgme: Video game music emulation/playback support')
+ 'libmad: MPEG codec support'
+ 'flac: FLAC codec support'
+ 'libgme: Video game music emulation/playback support')
makedepends=('alsa-lib'
- 'cjson'
- 'desktop-file-utils'
- 'freetype2'
- 'flac'
- 'git'
- 'ncurses'
- 'sdl2'
- 'xa'
- 'libgme'
- 'libancient'
- 'libdiscid'
- 'libmad'
- 'libjpeg-turbo'
- 'libpng'
- 'libvorbis')
+ 'cjson'
+ 'desktop-file-utils'
+ 'freetype2'
+ 'flac'
+ 'git'
+ 'ncurses'
+ 'sdl2'
+ 'xa'
+ 'libgme'
+ 'libancient'
+ 'libdiscid'
+ 'libmad'
+ 'libjpeg-turbo'
+ 'libpng'
+ 'libvorbis')
pkgver() {
cd $_pkgbase
- echo "$(git describe --tags | sed 's/^v//; s/-/.r/; s/-g/./')"
+ echo "$(git describe --tags | sed 's/^v//; s/-/.r/; s/-g/./')"
}
prepare() {
cd $_pkgbase
- git submodule init
- git submodule update --init --recursive
+ git submodule init
+ git submodule update --init --recursive
}
build() {
- cd $_pkgbase
- ./configure --prefix=/usr --sysconfdir=/etc --with-builtin=core cross_compiling=yes\
- --without-update-desktop-database\
- --without-update-mime-database\
- --with-unifont-ttf=/usr/share/fonts/Unifont/Unifont.ttf\
- --with-unifont-csur-ttf=/usr/share/fonts/Unifont/Unifont_CSUR.ttf\
- --with-unifont-upper-ttf=/usr/share/fonts/Unifont/Unifont_Upper.ttf
- make DESTDIR="$pkgdir" subdirs ocp ocp.hlp
+ cd $_pkgbase
+ ./configure --prefix=/usr --sysconfdir=/etc --with-builtin=core cross_compiling=yes\
+ --without-update-desktop-database\
+ --without-update-mime-database\
+ --with-unifont-ttf=/usr/share/fonts/Unifont/Unifont.ttf\
+ --with-unifont-csur-ttf=/usr/share/fonts/Unifont/Unifont_CSUR.ttf\
+ --with-unifont-upper-ttf=/usr/share/fonts/Unifont/Unifont_Upper.ttf
+ make DESTDIR="$pkgdir" subdirs ocp ocp.hlp
}
package_ocp-sdl2-git() {
- provides=(${_pkgbase}=${pkgver})
- conflicts=('ocp' 'ocp-curses')
- install=${_pkgbase}.install
- depends=('alsa-lib'
- 'bzip2'
- 'cjson'
- 'freetype2'
- 'hicolor-icon-theme'
- 'ncurses'
- 'sdl2'
- 'shared-mime-info'
- 'zlib'
- 'libancient'
- 'libdiscid'
- 'libjpeg-turbo'
- 'libpng'
- 'ttf-unifont')
- cd $_pkgbase
- ./configure --prefix=/usr --sysconfdir=/etc --with-builtin=core cross_compiling=yes\
- --without-sdl --without-x11\
- --without-update-desktop-database\
- --without-update-mime-database\
- --with-unifont-ttf=/usr/share/fonts/Unifont/Unifont.ttf\
- --with-unifont-csur-ttf=/usr/share/fonts/Unifont/Unifont_CSUR.ttf\
- --with-unifont-upper-ttf=/usr/share/fonts/Unifont/Unifont_Upper.ttf
- make DESTDIR="$pkgdir" libocp.so
- make DESTDIR="$pkgdir" install
+ provides=(${_pkgbase}=${pkgver})
+ conflicts=('ocp' 'ocp-curses')
+ install=${_pkgbase}.install
+ depends=('alsa-lib'
+ 'bzip2'
+ 'cjson'
+ 'freetype2'
+ 'hicolor-icon-theme'
+ 'ncurses'
+ 'sdl2'
+ 'shared-mime-info'
+ 'zlib'
+ 'libancient'
+ 'libdiscid'
+ 'libjpeg-turbo'
+ 'libpng'
+ 'ttf-unifont')
+ cd $_pkgbase
+ ./configure --prefix=/usr --sysconfdir=/etc --with-builtin=core cross_compiling=yes\
+ --without-sdl --without-x11\
+ --without-update-desktop-database\
+ --without-update-mime-database\
+ --with-unifont-ttf=/usr/share/fonts/Unifont/Unifont.ttf\
+ --with-unifont-csur-ttf=/usr/share/fonts/Unifont/Unifont_CSUR.ttf\
+ --with-unifont-upper-ttf=/usr/share/fonts/Unifont/Unifont_Upper.ttf
+ make DESTDIR="$pkgdir" libocp.so
+ make DESTDIR="$pkgdir" install
}
package_ocp-git() {
- provides=(${_pkgbase}=${pkgver})
- conflicts=('ocp' 'ocp-curses')
- depends=('alsa-lib'
- 'bzip2'
- 'cjson'
- 'ncurses'
- 'zlib'
- 'libancient'
- 'libdiscid')
- cd $_pkgbase
- ./configure --prefix=/usr --sysconfdir=/etc --with-builtin=core\
- --without-x11 --without-sdl --without-sdl2\
- --without-update-desktop-database\
- --without-update-mime-database
- make DESTDIR="$pkgdir" libocp.so
- make DESTDIR="$pkgdir" install
+ provides=(${_pkgbase}=${pkgver})
+ conflicts=('ocp' 'ocp-curses')
+ depends=('alsa-lib'
+ 'bzip2'
+ 'cjson'
+ 'ncurses'
+ 'zlib'
+ 'libancient'
+ 'libdiscid')
+ cd $_pkgbase
+ ./configure --prefix=/usr --sysconfdir=/etc --with-builtin=core\
+ --without-x11 --without-sdl --without-sdl2\
+ --without-update-desktop-database\
+ --without-update-mime-database
+ make DESTDIR="$pkgdir" libocp.so
+ make DESTDIR="$pkgdir" install
}