summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorOssi Saukko2015-09-09 16:51:44 +0300
committerOssi Saukko2015-09-09 16:51:44 +0300
commit6acb873e1425a0ca4c2dd69c067d635b841c96de (patch)
tree13ce56c9a1bd7b93c2f22d6ac72f28923eb7d687
downloadaur-6acb873e1425a0ca4c2dd69c067d635b841c96de.tar.gz
Initial import
-rw-r--r--.SRCINFO27
-rw-r--r--PKGBUILD45
-rw-r--r--ocp-git.install25
3 files changed, 97 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f9a5ffe95459
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,27 @@
+pkgbase = ocp-git
+ pkgdesc = A music file player for Linux, Unix, DOS and Windows 95-ME, XP.
+ pkgver = 0.1.22.r62.3a44284
+ pkgrel = 1
+ url = http://stian.cubic.org/project-ocp.php
+ install = ocp-git.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ depends = hicolor-icon-theme
+ depends = libxpm
+ depends = libxxf86vm
+ optdepends = adplug: for OPL formats support
+ optdepends = alsa-lib: for ALSA output
+ optdepends = flac: for FLAC audio support
+ optdepends = libmad: for MPEG audio support
+ optdepends = libsidplay: for SID music support
+ optdepends = libvorbis: for Vorbis audio support
+ optdepends = sdl: for SDL user interface support
+ conflicts = ocp
+ replaces = opencubicplayer-git
+ source = ocp::git://git.code.sf.net/p/opencubicplayer/code
+ md5sums = SKIP
+
+pkgname = ocp-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c89b8ee9db44
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+# Maintainer: Ossi Saukko <osaukko at gmail dot com>
+_name=ocp
+pkgname=ocp-git
+pkgver=0.1.22.r62.3a44284
+pkgrel=1
+pkgdesc="A music file player for Linux, Unix, DOS and Windows 95-ME, XP."
+arch=('i686' 'x86_64')
+url="http://stian.cubic.org/project-ocp.php"
+license=('GPL')
+depends=('hicolor-icon-theme'
+ 'libxpm'
+ 'libxxf86vm')
+optdepends=('adplug: for OPL formats support'
+ 'alsa-lib: for ALSA output'
+ 'flac: for FLAC audio support'
+ 'libmad: for MPEG audio support'
+ 'libsidplay: for SID music support'
+ 'libvorbis: for Vorbis audio support'
+ 'sdl: for SDL user interface support')
+makedepends=('git')
+provides=("${_name}=${pkgver}")
+conflicts=("${_name}")
+replaces=('opencubicplayer-git')
+install=$pkgname.install
+source=("${_name}::git://git.code.sf.net/p/opencubicplayer/code")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/${_name}"
+ printf "%s.r%s.%s" "$(grep \^AC_INIT configure.ac|cut -d, -f2|xargs)" \
+ "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "${srcdir}/${_name}"
+ ./configure --prefix=/usr
+
+ cd "${srcdir}/${_name}"
+ make
+}
+
+package() {
+ cd "${srcdir}/${_name}"
+ make DESTDIR="${pkgdir}" install
+}
diff --git a/ocp-git.install b/ocp-git.install
new file mode 100644
index 000000000000..a68f9cc68c5b
--- /dev/null
+++ b/ocp-git.install
@@ -0,0 +1,25 @@
+infodir=usr/share/info
+
+post_install() {
+ [ -x usr/bin/install-info ] || return 0
+ install-info $infodir/ocp.info.gz $infodir/dir 2> /dev/null
+ gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
+ update-desktop-database -q
+ echo
+ echo Please note that you need to rebuild this package after installing any of the optional dependencies.
+ echo
+}
+
+post_upgrade() {
+ post_install
+}
+
+pre_remove() {
+ install-info --delete $infodir/ocp.info.gz $infodir/dir 2> /dev/null
+}
+
+post_remove() {
+ update-desktop-database -q
+ gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
+}
+