summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorOssi Saukko2020-02-27 16:22:17 +0200
committerOssi Saukko2020-02-27 16:22:17 +0200
commit9967d9fa2408e7050d4cec77318786a75854c280 (patch)
tree6d727181f38a3510b9e5ae557592c26d32b7acff
parentc7a62d7ef886f3405916832428279049013c7ece (diff)
downloadaur-9967d9fa2408e7050d4cec77318786a75854c280.tar.gz
Update to 0.2.1.r380.1c5c7b1
The Open Cubic Player has replaced the libsidplay with the local fork of libsidplayfp. Therefore, libsidplay is not optional dependency anymore, but we do have two new make depends needed to build the Open Cubic Player. The new configuration file seems to support GCC up to version 10, and therefore we do not need the patching for configure script anymore.
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD10
2 files changed, 8 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7d6e57f3f403..c949b4f978a6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = ocp-git
pkgdesc = Open Cubic Player (GIT Version)
- pkgver = 0.2.1.r372.ed5da9c
+ pkgver = 0.2.1.r380.1c5c7b1
pkgrel = 1
url = http://stian.cubic.org/project-ocp.php
install = ocp-git.install
@@ -8,6 +8,8 @@ pkgbase = ocp-git
arch = x86_64
license = GPL
makedepends = git
+ makedepends = libsidplayfp
+ makedepends = xa
depends = hicolor-icon-theme
depends = libxpm
depends = libxxf86vm
@@ -15,11 +17,10 @@ pkgbase = ocp-git
optdepends = alsa-lib: for ALSA output
optdepends = flac: for FLAC audio support
optdepends = libmad: for MPEG audio support
- optdepends = libsidplay: for SID music support
optdepends = libvorbis: for Vorbis audio support
optdepends = sdl: for SDL user interface support
optdepends = sdl2: for SDL2 user interface support
- provides = ocp=0.2.1.r372.ed5da9c
+ provides = ocp=0.2.1.r380.1c5c7b1
conflicts = ocp
source = ocp::git://github.com/mywave82/opencubicplayer.git
md5sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 0489606f280c..d6e09533ab0c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Ossi Saukko <osaukko at gmail dot com>
_name=ocp
pkgname=ocp-git
-pkgver=0.2.1.r372.ed5da9c
+pkgver=0.2.1.r380.1c5c7b1
pkgrel=1
pkgdesc="Open Cubic Player (GIT Version)"
arch=('i686' 'x86_64')
@@ -14,11 +14,12 @@ optdepends=('adplug: for OPL formats support'
'alsa-lib: for ALSA output'
'flac: for FLAC audio support'
'libmad: for MPEG audio support'
- 'libsidplay: for SID music support'
'libvorbis: for Vorbis audio support'
'sdl: for SDL user interface support'
'sdl2: for SDL2 user interface support')
-makedepends=('git')
+makedepends=('git'
+ 'libsidplayfp'
+ 'xa')
provides=("${_name}=${pkgver}")
conflicts=("${_name}")
install=$pkgname.install
@@ -36,9 +37,6 @@ build() {
git submodule init
git submodule update
- # Adding support for new version of GCC
- sed -i.orig 's/\*|4\.\*|5\.\*|6\.\*|7\*/&|8*|9*/' configure
-
# If both SDL and SDL2 are installed, then disable SDL.
# Otherwise there are functions with similar names and linking fails.
CONFIG="--prefix=/usr --sysconfdir=/etc --with-timidity-default-path=/etc/timidity++/"