summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPatrick Northon2021-02-09 14:19:28 -0500
committerPatrick Northon2021-02-09 14:19:28 -0500
commitbacceafc3210d9efabb89e48d9d039e973458422 (patch)
treed3a1fb81c20bff07de9b15d75e6484411d58363a
parent0b6646451a3c2d843877ed8946359babc885c752 (diff)
downloadaur-bacceafc3210d9efabb89e48d9d039e973458422.tar.gz
Updated urls and dependencies.
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD35
2 files changed, 27 insertions, 23 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fec7b749ac45..c371f7b76258 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,12 @@
pkgbase = ocropy-git
pkgdesc = Python-based OCR package using recurrent neural networks (formerly ocropus)
- pkgver = 737.8b88583
+ pkgver = 998.fe78a04
pkgrel = 1
- url = https://github.com/tmbdev/ocropy
+ url = https://github.com/ocropus/ocropy
arch = any
license = APACHE
makedepends = git
- depends = python-imaging
+ depends = python2-imaging
depends = python2-scipy
depends = python2-matplotlib
depends = python2-pytables
@@ -14,11 +14,10 @@ pkgbase = ocropy-git
depends = opencv
depends = python2-beautifulsoup4
provides = ocropy
- conflicts = ocropy
- source = git+https://github.com/tmbdev/ocropy.git
- source = http://www.tmbdev.net/en-default.pyrnn.gz
- md5sums = SKIP
- md5sums = cedd140c7d7650e910f0550ad0f04727
+ source = git+https://github.com/ocropus/ocropy.git
+ source = https://github.com/zuphilip/ocropy-models/raw/master/en-default.pyrnn.gz
+ sha256sums = SKIP
+ sha256sums = b749ec701a53915183963c3814a288de7da5a38261bd9008e0ae0674c71cd1f7
pkgname = ocropy-git
diff --git a/PKGBUILD b/PKGBUILD
index 387d03ebfe87..955f5b4a91f2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,33 +1,38 @@
-# Maintainer: Lukas Jirkovsky <l.jirkovsky@gmail.com>
-pkgname=ocropy-git
-pkgver=737.8b88583
+# Contributor: Patrick Northon <northon_patrick3@yahoo.ca>
+# Contributor: Lukas Jirkovsky <l.jirkovsky@gmail.com>
+
+_pkgname=ocropy
+pkgname=${_pkgname}-git
+pkgver=998.fe78a04
pkgrel=1
pkgdesc="Python-based OCR package using recurrent neural networks (formerly ocropus)"
arch=('any')
-url="https://github.com/tmbdev/ocropy"
+url="https://github.com/ocropus/${_pkgname}"
license=('APACHE')
-depends=('python-imaging' 'python2-scipy' 'python2-matplotlib' 'python2-pytables'
+depends=('python2-imaging' 'python2-scipy' 'python2-matplotlib' 'python2-pytables'
'imagemagick' 'opencv' 'python2-beautifulsoup4')
makedepends=('git')
-provides=('ocropy')
-conflicts=('ocropy')
-source=('git+https://github.com/tmbdev/ocropy.git'
- "http://www.tmbdev.net/en-default.pyrnn.gz")
-md5sums=('SKIP'
- 'cedd140c7d7650e910f0550ad0f04727')
+provides=("${_pkgname}")
+source=("git+https://github.com/ocropus/${_pkgname}.git"
+ "https://github.com/zuphilip/ocropy-models/raw/master/en-default.pyrnn.gz")
+sha256sums=('SKIP'
+ 'b749ec701a53915183963c3814a288de7da5a38261bd9008e0ae0674c71cd1f7')
pkgver() {
- cd "$srcdir/ocropy"
+ cd "$srcdir/${_pkgname}"
echo $(git rev-list --count master).$(git rev-parse --short master)
}
prepare() {
- cd "$srcdir/ocropy"
+ cd "$srcdir/${_pkgname}"
cp "$srcdir/en-default.pyrnn.gz" models
+
+ sed -i 's|tostring|tobytes|' ocrolib/common.py
+ sed -i 's|PIL\.Image\.fromstring|PIL\.Image\.frombytes|' ocrolib/common.py
}
build() {
- cd "$srcdir/ocropy"
+ cd "$srcdir/${_pkgname}"
# make sure python2 is always used
find . -type f -name "*.py" -exec sed -i 's|^#!.*python$|&2|' '{}' ';'
@@ -40,7 +45,7 @@ build() {
}
package() {
- cd "$srcdir/ocropy"
+ cd "$srcdir/${_pkgname}"
python2 setup.py install --root="$pkgdir/" --optimize=1
}