summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorchrys2015-09-15 20:39:37 +0200
committerchrys2015-09-15 20:39:37 +0200
commite910974425d8da2d03ad6c8eb31c2cce057d03dd (patch)
tree707ff88c9e86416b993fe4ca24d1db09e99ca882
downloadaur-e910974425d8da2d03ad6c8eb31c2cce057d03dd.tar.gz
initial ocrpdf release 0.2.0
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD18
-rw-r--r--ocrpdf.install3
3 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5f8f6f1d8bd6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = ocrpdf
+ pkgdesc = OCR a PDF file and make it browsable
+ pkgver = 0.2.0
+ pkgrel = 1
+ url = http://www.crivatec.de
+ install = ocrpdf.install
+ arch = any
+ license = GPL
+ depends = python-pypdf2
+ depends = pythonmagick
+ depends = python-pillow
+ depends = python-tesserwrap
+ source = http://crivatec.de/page/uploads/Downloads/Accessible%20Games/ocrpdf-0.2.0.tar.xz
+ md5sums = 1275a555a46ae8dba0011ed24bbb0daf
+
+pkgname = ocrpdf
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..35f7d1117b49
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,18 @@
+# Maintainer: Chrys <mail@chrys.de>
+pkgname=ocrpdf
+pkgver=0.2.0
+pkgrel=1
+pkgdesc="OCR a PDF file and make it browsable"
+arch=('any')
+url="http://www.crivatec.de"
+license=('GPL')
+groups=()
+depends=('python-pypdf2' 'pythonmagick' 'python-pillow' 'python-tesserwrap')
+source=("http://crivatec.de/page/uploads/Downloads/Accessible%20Games/$pkgname-$pkgver.tar.xz")
+install='ocrpdf.install'
+md5sums=("1275a555a46ae8dba0011ed24bbb0daf")
+
+package() {
+ cd "${srcdir}/"
+ install -Dm755 ocrpdf "$pkgdir/usr/bin/ocrpdf"
+}
diff --git a/ocrpdf.install b/ocrpdf.install
new file mode 100644
index 000000000000..c5fe4ebce71c
--- /dev/null
+++ b/ocrpdf.install
@@ -0,0 +1,3 @@
+post_install() {
+ echo "you need to install tesseract-data-<language_code> for working with this application"
+}