summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavid Birks2019-08-07 23:36:02 -0400
committerDavid Birks2019-08-07 23:36:02 -0400
commitd78b028d13f82e95cc6cb8ef4b15383b359c7175 (patch)
tree3102122780e5f7cff4bfd94018efe0be8f232ad6
downloadaur-d78b028d13f82e95cc6cb8ef4b15383b359c7175.tar.gz
Initial commit of 0.5.1
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD22
3 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f2e1b23f952d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = octant
+ pkgdesc = A tool for developers to understand how applications run on a Kubernetes cluster
+ pkgver = 0.5.1
+ pkgrel = 1
+ url = https://github.com/vmware/octant
+ arch = x86_64
+ license = Apache
+ makedepends = go
+ makedepends = npm
+ depends = kubectl
+ source = octant-0.5.1.tar.gz::https://github.com/vmware/octant/archive/v0.5.1.tar.gz
+ sha256sums = 29d43f526f79ee20f97688b28598f6281c405de46e56938822a9e189a6651621
+
+pkgname = octant
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..e0f8ccd78030
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*.tar.gz
+*.xz
+src
+pkg
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2583dc09df2c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: David Birks <david@tellus.space>
+
+pkgname=octant
+pkgdesc='A tool for developers to understand how applications run on a Kubernetes cluster'
+pkgver=0.5.1
+pkgrel=1
+arch=('x86_64')
+license=('Apache')
+url='https://github.com/vmware/octant'
+depends=('kubectl')
+makedepends=('go' 'npm')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/vmware/octant/archive/v$pkgver.tar.gz")
+sha256sums=('29d43f526f79ee20f97688b28598f6281c405de46e56938822a9e189a6651621')
+
+build() {
+ cd $pkgname-$pkgver
+ make go-install ci
+}
+
+package() {
+ install -Dm 755 "$srcdir/$pkgname-$pkgver/build/$pkgname" "$pkgdir/usr/bin/$pkgname"
+}