summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMathias Buhr2023-02-14 22:02:26 +0100
committerMathias Buhr2023-02-14 22:02:26 +0100
commitad32f6328c2dd904ef7641ed459a1145400c9a0d (patch)
tree56ab4c4ccb6e168b90dc35e280dc26b25ad6296d
parent4a08922c90bd402707afdae8a48df3859bef77bb (diff)
downloadaur-ad32f6328c2dd904ef7641ed459a1145400c9a0d.tar.gz
Update to 0.8.3
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD8
2 files changed, 7 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e8111bb7dc61..1d08d409b6c3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = octasine
pkgdesc = VST2 frequency modulation synthesizer written in Rust
- pkgver = 0.8.1
+ pkgver = 0.8.3
pkgrel = 1
url = https://github.com/greatest-ape/OctaSine
arch = x86_64
@@ -18,7 +18,7 @@ pkgbase = octasine
depends = graphite
depends = glib2
depends = pcre
- source = https://github.com/greatest-ape/OctaSine/archive/refs/tags/v0.8.1.tar.gz
- sha256sums = e7cbfa06d950e02867570084b0c50c76beeff1db2a203d0a033721b9296fcba1
+ source = https://github.com/greatest-ape/OctaSine/archive/refs/tags/v0.8.3.tar.gz
+ sha256sums = 8ddad2874165bd7d0b28f87c0d8cd7eb55021607deb79eed1f4e2890b13f003c
pkgname = octasine
diff --git a/PKGBUILD b/PKGBUILD
index 97de00b6ed72..9421617131d7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Mathias Buhr <napcode@aparatus.de>
pkgname=octasine
-pkgver=0.8.1
+pkgver=0.8.3
pkgrel=1
pkgdesc='VST2 frequency modulation synthesizer written in Rust'
arch=('x86_64')
@@ -25,15 +25,15 @@ makedepends=(
)
source=(https://github.com/greatest-ape/OctaSine/archive/refs/tags/v${pkgver}.tar.gz)
-sha256sums=('e7cbfa06d950e02867570084b0c50c76beeff1db2a203d0a033721b9296fcba1')
+sha256sums=('8ddad2874165bd7d0b28f87c0d8cd7eb55021607deb79eed1f4e2890b13f003c')
build() {
cd OctaSine-${pkgver}
- cargo build --release -p octasine-vst2-plugin
+ cargo xtask bundle octasine --release --verbose --no-default-features --features "glow vst2"
}
package() {
mkdir -p ${pkgdir}/usr/lib/vst
- cp ${srcdir}/OctaSine-${pkgver}/target/release/liboctasine.so ${pkgdir}/usr/lib/vst/OctaSine.so
+ cp ${srcdir}/OctaSine-${pkgver}/target/bundled/octasine.so ${pkgdir}/usr/lib/vst/OctaSine.so
chmod +x ${pkgdir}/usr/lib/vst/OctaSine.so
}