summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorClemens Buchacher2015-06-10 10:32:09 +0200
committerClemens Buchacher2015-06-10 10:35:03 +0200
commit23760dc9af247ee4f8a07297dbce904d29adb646 (patch)
tree840b9054f21526cd05d9fe5326b31b3cb66d973b
downloadaur-23760dc9af247ee4f8a07297dbce904d29adb646.tar.gz
control 2.8.1
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD54
-rw-r--r--octave-control.install13
4 files changed, 89 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a6c7da7f142f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = octave-control
+ pkgdesc = Computer-Aided Control System Design (CACSD) Tools for GNU Octave, based on the proven SLICOT Library
+ pkgver = 2.8.1
+ pkgrel = 1
+ url = http://octave.sourceforge.net/control/
+ install = octave-control.install
+ arch = any
+ groups = octave-forge
+ license = GPL3
+ makedepends = gcc-fortran
+ depends = octave>=3.8.0
+ noextract = control-2.8.1.tar.gz
+ options = !makeflags
+ source = http://downloads.sourceforge.net/octave/control-2.8.1.tar.gz
+ md5sums = 0b6141a0937c9be83cabb49256d0f3c8
+
+pkgname = octave-control
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..ef46e7bf4e8c
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*.tar.gz
+*.tar.xz
+/src/
+/pkg/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..42c4a1023dbb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,54 @@
+#
+# Maintainer: Clemens Buchacher <drizzd@aon.at>
+#
+# You can use the newpkg script from
+# https://github.com/drizzd/octave-forge-archlinux to automatically generate
+# new octave-forge PKGBUILDs or update existing ones. Patches welcome.
+#
+
+_pack=control
+pkgname=octave-$_pack
+pkgver=2.8.1
+pkgrel=1
+pkgdesc="Computer-Aided Control System Design (CACSD) Tools for GNU Octave, based on the proven SLICOT Library"
+arch=(any)
+url="http://octave.sourceforge.net/$_pack/"
+license=('GPL3')
+groups=('octave-forge')
+depends=('octave>=3.8.0')
+makedepends=('gcc-fortran')
+optdepends=()
+backup=()
+options=('!makeflags')
+install=$pkgname.install
+_archive=$_pack-$pkgver.tar.gz
+source=("http://downloads.sourceforge.net/octave/$_archive")
+noextract=("$_archive")
+md5sums=('0b6141a0937c9be83cabb49256d0f3c8')
+
+_install_dir() {
+ src=$1
+ dst=$2
+ mkdir -p "$(dirname "$dst")"
+ cp -rT "$src" "$dst"
+}
+
+build() {
+ _prefix="$srcdir"/install_prefix
+ _archprefix="$srcdir"/install_archprefix
+ mkdir -p "$_prefix" "$_archprefix"
+ cd "$srcdir"
+ octave -q -f --eval "$(cat <<-EOF
+ pkg local_list octave_packages;
+ pkg prefix $_prefix $_archprefix;
+ pkg install -verbose -nodeps $_archive;
+ EOF
+ )"
+}
+
+package() {
+ prefix=$pkgdir/usr/share/octave/packages
+ archprefix=$pkgdir/usr/lib/octave/packages
+ _install_dir "$srcdir"/install_prefix "$prefix"
+ _install_dir "$srcdir"/install_archprefix "$archprefix"
+}
diff --git a/octave-control.install b/octave-control.install
new file mode 100644
index 000000000000..be6e3265f7cd
--- /dev/null
+++ b/octave-control.install
@@ -0,0 +1,13 @@
+_pack=control
+
+post_install() {
+ octave -q -f --eval "pkg rebuild -global $_pack"
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ octave -q -f --eval "pkg rebuild -global"
+}