summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorClemens Buchacher2015-06-10 11:12:33 +0200
committerClemens Buchacher2015-06-10 11:12:33 +0200
commit292f9b0abfec5e209f3e844429e270078927e627 (patch)
treecf58cd988e1bd929e1017726b32d3649f033a6f3
downloadaur-292f9b0abfec5e209f3e844429e270078927e627.tar.gz
data-smoothing 1.3.0-2
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD54
-rw-r--r--octave-data-smoothing.install13
4 files changed, 88 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e40d5f2db660
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = octave-data-smoothing
+ pkgdesc = Algorithms for smoothing noisy data
+ pkgver = 1.3.0
+ pkgrel = 2
+ url = http://octave.sourceforge.net/data-smoothing/
+ install = octave-data-smoothing.install
+ arch = any
+ groups = octave-forge
+ license = GPL3
+ depends = octave>=3.6.0
+ depends = octave-optim>=1.0.3
+ noextract = data-smoothing-1.3.0.tar.gz
+ source = http://downloads.sourceforge.net/octave/data-smoothing-1.3.0.tar.gz
+ md5sums = d8fc52ed097b5096f5e7ea16dc5ab343
+
+pkgname = octave-data-smoothing
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..ef46e7bf4e8c
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*.tar.gz
+*.tar.xz
+/src/
+/pkg/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..53af760bc036
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,54 @@
+#
+# Maintainer: Clemens Buchacher <drizzd@aon.at>
+#
+# You can use the newpkg script from
+# https://github.com/drizzd/octave-forge-archlinux to automatically generate
+# new octave-forge PKGBUILDs or update existing ones. Patches welcome.
+#
+
+_pack=data-smoothing
+pkgname=octave-$_pack
+pkgver=1.3.0
+pkgrel=2
+pkgdesc="Algorithms for smoothing noisy data"
+arch=(any)
+url="http://octave.sourceforge.net/$_pack/"
+license=('GPL3')
+groups=('octave-forge')
+depends=('octave>=3.6.0' 'octave-optim>=1.0.3')
+makedepends=()
+optdepends=()
+backup=()
+options=()
+install=$pkgname.install
+_archive=$_pack-$pkgver.tar.gz
+source=("http://downloads.sourceforge.net/octave/$_archive")
+noextract=("$_archive")
+md5sums=('d8fc52ed097b5096f5e7ea16dc5ab343')
+
+_install_dir() {
+ src=$1
+ dst=$2
+ mkdir -p "$(dirname "$dst")"
+ cp -rT "$src" "$dst"
+}
+
+build() {
+ _prefix="$srcdir"/install_prefix
+ _archprefix="$srcdir"/install_archprefix
+ mkdir -p "$_prefix" "$_archprefix"
+ cd "$srcdir"
+ octave -q -f --eval "$(cat <<-EOF
+ pkg local_list octave_packages;
+ pkg prefix $_prefix $_archprefix;
+ pkg install -verbose -nodeps $_archive;
+ EOF
+ )"
+}
+
+package() {
+ prefix=$pkgdir/usr/share/octave/packages
+ archprefix=$pkgdir/usr/lib/octave/packages
+ _install_dir "$srcdir"/install_prefix "$prefix"
+ _install_dir "$srcdir"/install_archprefix "$archprefix"
+}
diff --git a/octave-data-smoothing.install b/octave-data-smoothing.install
new file mode 100644
index 000000000000..62fe9d6d6802
--- /dev/null
+++ b/octave-data-smoothing.install
@@ -0,0 +1,13 @@
+_pack=data-smoothing
+
+post_install() {
+ octave -q -f --eval "pkg rebuild -global $_pack"
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ octave -q -f --eval "pkg rebuild -global"
+}