summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorwangjiezhe2016-12-19 20:48:00 +0800
committerwangjiezhe2016-12-19 20:48:00 +0800
commit97c2ea9ba49c75bbd96bb96e10a8fdba5ca7f1de (patch)
treeeecbfa625150c1b9550135e211f5e0cf55eca989
parent292f9b0abfec5e209f3e844429e270078927e627 (diff)
downloadaur-97c2ea9ba49c75bbd96bb96e10a8fdba5ca7f1de.tar.gz
rebuild for octave 4.2.0
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD8
-rw-r--r--octave-data-smoothing.install8
3 files changed, 15 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e40d5f2db660..dae3113cbb08 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,9 @@
+# Generated by mksrcinfo v8
+# Mon Dec 19 12:47:48 UTC 2016
pkgbase = octave-data-smoothing
pkgdesc = Algorithms for smoothing noisy data
pkgver = 1.3.0
- pkgrel = 2
+ pkgrel = 4
url = http://octave.sourceforge.net/data-smoothing/
install = octave-data-smoothing.install
arch = any
diff --git a/PKGBUILD b/PKGBUILD
index 53af760bc036..d92bb81bf4f7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,7 +9,7 @@
_pack=data-smoothing
pkgname=octave-$_pack
pkgver=1.3.0
-pkgrel=2
+pkgrel=4
pkgdesc="Algorithms for smoothing noisy data"
arch=(any)
url="http://octave.sourceforge.net/$_pack/"
@@ -26,6 +26,10 @@ source=("http://downloads.sourceforge.net/octave/$_archive")
noextract=("$_archive")
md5sums=('d8fc52ed097b5096f5e7ea16dc5ab343')
+_octave_run() {
+ octave --no-history --no-init-file --no-window-system -q -f --eval "$*"
+}
+
_install_dir() {
src=$1
dst=$2
@@ -38,7 +42,7 @@ build() {
_archprefix="$srcdir"/install_archprefix
mkdir -p "$_prefix" "$_archprefix"
cd "$srcdir"
- octave -q -f --eval "$(cat <<-EOF
+ _octave_run "$(cat <<-EOF
pkg local_list octave_packages;
pkg prefix $_prefix $_archprefix;
pkg install -verbose -nodeps $_archive;
diff --git a/octave-data-smoothing.install b/octave-data-smoothing.install
index 62fe9d6d6802..ea8ee1c74f96 100644
--- a/octave-data-smoothing.install
+++ b/octave-data-smoothing.install
@@ -1,7 +1,11 @@
_pack=data-smoothing
+_octave_run() {
+ octave --no-history --no-init-file --no-window-system -q -f --eval "$*"
+}
+
post_install() {
- octave -q -f --eval "pkg rebuild -global $_pack"
+ _octave_run "pkg rebuild -global $_pack"
}
post_upgrade() {
@@ -9,5 +13,5 @@ post_upgrade() {
}
post_remove() {
- octave -q -f --eval "pkg rebuild -global"
+ _octave_run "pkg rebuild -global"
}