summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorwangjiezhe2017-02-26 21:23:44 +0800
committerwangjiezhe2017-02-26 21:27:28 +0800
commit49414161e2affa3ce204cd4e8afc9c40ee352401 (patch)
tree76d0c80da244b3bad40aa62797be84342ed1ab4a
downloadaur-49414161e2affa3ce204cd4e8afc9c40ee352401.tar.gz
Initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD58
-rw-r--r--octave-dicom.install17
4 files changed, 98 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2381582a6103
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+# Generated by mksrcinfo v8
+# Sun Feb 26 13:25:46 UTC 2017
+pkgbase = octave-dicom
+ pkgdesc = Digital communications in medicine (DICOM) file io. Depends on Grassroots DICOM (GDCM). This package is not available in repos for all distros. Contributors: Judd Storrs, Kris Thielemans, John Donoghue
+ pkgver = 0.2.0
+ pkgrel = 1
+ url = http://octave.sourceforge.net/dicom/
+ install = octave-dicom.install
+ arch = any
+ groups = octave-forge
+ license = GPL3
+ depends = octave
+ depends = gdcm>2.0.16
+ noextract = dicom-0.2.0.tar.gz
+ source = http://downloads.sourceforge.net/octave/dicom-0.2.0.tar.gz
+ md5sums = e35f7964fadfa7f29fb03171159e18cb
+
+pkgname = octave-dicom
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..b20752a93bec
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*.tar.gz
+*.tar.xz
+pkg/
+src/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..aa382e75aa00
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,58 @@
+#
+# Maintainer: Clemens Buchacher <drizzd@aon.at>
+#
+# You can use the newpkg script from
+# https://github.com/drizzd/octave-forge-archlinux to automatically generate
+# new octave-forge PKGBUILDs or update existing ones. Patches welcome.
+#
+
+_pack=dicom
+pkgname=octave-$_pack
+pkgver=0.2.0
+pkgrel=1
+pkgdesc="Digital communications in medicine (DICOM) file io. Depends on Grassroots DICOM (GDCM). This package is not available in repos for all distros. Contributors: Judd Storrs, Kris Thielemans, John Donoghue"
+arch=(any)
+url="http://octave.sourceforge.net/$_pack/"
+license=('GPL3')
+groups=('octave-forge')
+depends=('octave' 'gdcm>2.0.16')
+makedepends=()
+optdepends=()
+backup=()
+options=()
+install=$pkgname.install
+_archive=$_pack-$pkgver.tar.gz
+source=("http://downloads.sourceforge.net/octave/$_archive")
+noextract=("$_archive")
+md5sums=('e35f7964fadfa7f29fb03171159e18cb')
+
+_octave_run() {
+ octave --no-history --no-init-file --no-window-system -q -f --eval "$*"
+}
+
+_install_dir() {
+ src=$1
+ dst=$2
+ mkdir -p "$(dirname "$dst")"
+ cp -rT "$src" "$dst"
+}
+
+build() {
+ _prefix="$srcdir"/install_prefix
+ _archprefix="$srcdir"/install_archprefix
+ mkdir -p "$_prefix" "$_archprefix"
+ cd "$srcdir"
+ _octave_run "$(cat <<-EOF
+ pkg local_list octave_packages;
+ pkg prefix $_prefix $_archprefix;
+ pkg install -verbose -nodeps $_archive;
+ EOF
+ )"
+}
+
+package() {
+ prefix=$pkgdir/usr/share/octave/packages
+ archprefix=$pkgdir/usr/lib/octave/packages
+ _install_dir "$srcdir"/install_prefix "$prefix"
+ _install_dir "$srcdir"/install_archprefix "$archprefix"
+}
diff --git a/octave-dicom.install b/octave-dicom.install
new file mode 100644
index 000000000000..f830fa941248
--- /dev/null
+++ b/octave-dicom.install
@@ -0,0 +1,17 @@
+_pack=dicom
+
+_octave_run() {
+ octave --no-history --no-init-file --no-window-system -q -f --eval "$*"
+}
+
+post_install() {
+ _octave_run "pkg rebuild -global $_pack"
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ _octave_run "pkg rebuild -global"
+}