summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarlos Aznarán Laos2022-01-23 14:13:45 -0500
committerCarlos Aznarán Laos2022-01-23 14:13:45 -0500
commit97f471c26d4a30dfc1a2805516f867f47d73da12 (patch)
tree46f85146df09082626c7c4e40759277e24e9d4a1
parentc0d18455e261c6f6916c351c64982d020f0b0a3f (diff)
downloadaur-97f471c26d4a30dfc1a2805516f867f47d73da12.tar.gz
Update upstream URL
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD52
2 files changed, 30 insertions, 29 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9ca61ee94dfc..dea325d6900f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -2,15 +2,14 @@ pkgbase = octave-divand
pkgdesc = divand performs an n-dimensional variational analysis (interpolation) of arbitrarily located observations.
pkgver = 1.1.2
pkgrel = 3
- url = https://octave.sourceforge.net/divand/
+ url = https://octave.sourceforge.io/divand
install = octave-divand.install
arch = any
groups = octave-forge
- license = GPL
+ license = GPL2
depends = octave>=3.4.0
noextract = divand-1.1.2.tar.gz
source = https://downloads.sourceforge.net/octave/divand-1.1.2.tar.gz
- sha256sums = afaa9069daef3ae0fd9a9bb1031b7c2fbc03e7e7951245eef9d4b53364f9aa5a
+ sha512sums = 341a93bcdaf5e302bc02a53a88586887d372c0d1a319a2690acf5fe2d467e19b0af3ef38f3d385773f2becc0d0cb459bc46030fed31fa10e0b0b4ff096336b5e
pkgname = octave-divand
-
diff --git a/PKGBUILD b/PKGBUILD
index 8aaf2fa85292..df91ac0f7354 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,7 @@
#
-# Maintainer: Clemens Buchacher <drizzd@aon.at>
-# Contributor: wangjiezhe <wangjiezhe AT yandex DOT com>
+# Maintainer: Carlos Aznarán <caznaranl@uni.pe>
+# Contributor: wangjiezhe <wangjiezhe@gmail.com>
+# Contributor: Clemens Buchacher <drizzd@aon.at>
#
# You can use the newpkg script from
# https://github.com/drizzd/octave-forge-archlinux to automatically generate
@@ -8,52 +9,53 @@
#
_pack=divand
-pkgname=octave-$_pack
+pkgname=octave-${_pack}
pkgver=1.1.2
pkgrel=3
pkgdesc="divand performs an n-dimensional variational analysis (interpolation) of arbitrarily located observations."
arch=(any)
-url="https://octave.sourceforge.net/$_pack/"
-license=('GPL')
+url="https://octave.sourceforge.io/${_pack}"
+license=('GPL2')
groups=('octave-forge')
depends=('octave>=3.4.0')
makedepends=()
optdepends=()
backup=()
options=()
-install=$pkgname.install
-_archive=$_pack-$pkgver.tar.gz
-source=("https://downloads.sourceforge.net/octave/$_archive")
-noextract=("$_archive")
-sha256sums=('afaa9069daef3ae0fd9a9bb1031b7c2fbc03e7e7951245eef9d4b53364f9aa5a')
+install=${pkgname}.install
+_archive=${_pack}-${pkgver}.tar.gz
+source=("https://downloads.sourceforge.net/octave/${_archive}")
+noextract=("${_archive}")
+sha512sums=('341a93bcdaf5e302bc02a53a88586887d372c0d1a319a2690acf5fe2d467e19b0af3ef38f3d385773f2becc0d0cb459bc46030fed31fa10e0b0b4ff096336b5e')
_octave_run() {
- octave --no-history --no-init-file --no-window-system -q -f --eval "$*"
+ octave --no-history --no-init-file --no-window-system -q -f --eval "$*"
}
_install_dir() {
- src=$1
- dst=$2
- mkdir -p "$(dirname "$dst")"
- cp -rT "$src" "$dst"
+ src=$1
+ dst=$2
+ mkdir -p "$(dirname "$dst")"
+ cp -rT "$src" "$dst"
}
build() {
- _prefix="$srcdir"/install_prefix
- _archprefix="$srcdir"/install_archprefix
- mkdir -p "$_prefix" "$_archprefix"
- cd "$srcdir"
- _octave_run "$(cat <<-EOF
+ _prefix="$srcdir"/install_prefix
+ _archprefix="$srcdir"/install_archprefix
+ mkdir -p "$_prefix" "$_archprefix"
+ cd "$srcdir"
+ _octave_run "$(
+ cat <<-EOF
pkg local_list octave_packages;
pkg prefix $_prefix $_archprefix;
pkg install -verbose -nodeps $_archive;
EOF
- )"
+ )"
}
package() {
- prefix=$pkgdir/usr/share/octave/packages
- archprefix=$pkgdir/usr/lib/octave/packages
- _install_dir "$srcdir"/install_prefix "$prefix"
- _install_dir "$srcdir"/install_archprefix "$archprefix"
+ prefix=$pkgdir/usr/share/octave/packages
+ archprefix=$pkgdir/usr/lib/octave/packages
+ _install_dir "$srcdir"/install_prefix "$prefix"
+ _install_dir "$srcdir"/install_archprefix "$archprefix"
}