summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorwangjiezhe2015-10-27 18:39:23 +0800
committerwangjiezhe2015-10-27 18:39:23 +0800
commit2005d4292869b69a27c6ab95155507aea578afee (patch)
tree4165e40db903df84eb00fd728a6b5919f6747908
parent56dcc7399ee81b12196225c1b17c5e0b2bb3133b (diff)
downloadaur-2005d4292869b69a27c6ab95155507aea578afee.tar.gz
Use _octave_run
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD8
-rw-r--r--octave-econometrics.install8
3 files changed, 13 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4a4864eb1ffd..40097694f766 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = octave-econometrics
pkgdesc = Econometrics functions including MLE and GMM based techniques.
pkgver = 1.1.1
- pkgrel = 1
+ pkgrel = 2
url = http://octave.sourceforge.net/econometrics/
install = octave-econometrics.install
arch = any
diff --git a/PKGBUILD b/PKGBUILD
index 1654c55dac35..02ffa9f4e9a8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,7 +10,7 @@
_pack=econometrics
pkgname=octave-$_pack
pkgver=1.1.1
-pkgrel=1
+pkgrel=2
pkgdesc="Econometrics functions including MLE and GMM based techniques."
arch=(any)
url="http://octave.sourceforge.net/$_pack/"
@@ -27,6 +27,10 @@ source=("http://downloads.sourceforge.net/octave/$_archive")
noextract=("$_archive")
md5sums=('132e64c97c21dd2841f3f1957b3ffc16')
+_octave_run() {
+ octave --no-history --no-init-file --no-window-system -q -f --eval "$*"
+}
+
_install_dir() {
src=$1
dst=$2
@@ -39,7 +43,7 @@ build() {
_archprefix="$srcdir"/install_archprefix
mkdir -p "$_prefix" "$_archprefix"
cd "$srcdir"
- octave-cli -q -f --eval "$(cat <<-EOF
+ _octave_run "$(cat <<-EOF
pkg local_list octave_packages;
pkg prefix $_prefix $_archprefix;
pkg install -verbose -nodeps $_archive;
diff --git a/octave-econometrics.install b/octave-econometrics.install
index e90f9cf48816..ff33dc9dc40a 100644
--- a/octave-econometrics.install
+++ b/octave-econometrics.install
@@ -1,7 +1,11 @@
_pack=econometrics
+_octave_run() {
+ octave --no-history --no-init-file --no-window-system -q -f --eval "$*"
+}
+
post_install() {
- octave-cli -q -f --eval "pkg rebuild -global $_pack"
+ _octave_run "pkg rebuild -global $_pack"
}
post_upgrade() {
@@ -9,5 +13,5 @@ post_upgrade() {
}
post_remove() {
- octave-cli -q -f --eval "pkg rebuild -global"
+ _octave_run "pkg rebuild -global"
}