summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarlos Aznarán Laos2022-01-23 14:19:24 -0500
committerCarlos Aznarán Laos2022-01-23 14:19:24 -0500
commite9399de35f1461883119ccdbf6381c3d4b70a046 (patch)
tree9d07e185bd15b67ce388d97ceed2606849f10ff4
parentbf0add8fdc0fc4bcdf152c25c2ae2ecd5ba8c26b (diff)
downloadaur-e9399de35f1461883119ccdbf6381c3d4b70a046.tar.gz
Update upstream URL
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD52
2 files changed, 30 insertions, 29 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f1f37b885536..b1e4d912835e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = octave-econometrics
- pkgdesc = Econometrics functions including MLE and GMM based techniques.
+ pkgdesc = Econometrics functions including MLE and GMM based techniques
pkgver = 1.1.2
pkgrel = 1
- url = https://octave.sourceforge.net/econometrics/
+ url = https://octave.sourceforge.io/econometrics
install = octave-econometrics.install
arch = any
groups = octave-forge
@@ -11,7 +11,6 @@ pkgbase = octave-econometrics
depends = octave-optim
noextract = econometrics-1.1.2.tar.gz
source = https://downloads.sourceforge.net/octave/econometrics-1.1.2.tar.gz
- sha256sums = e2cca501f6b16ba4f2d5b4374dc3c80bd164472a30291dfd51947990263a3deb
+ sha512sums = 7db08c5acb2b791f842642f158e9a5026358db09d0c427ba8da0c472a107b73c55b59e2458fc7623d5ebc874092e3a69e3d953228164da11a9a90b17079b47b9
pkgname = octave-econometrics
-
diff --git a/PKGBUILD b/PKGBUILD
index 17b454d44642..5f5b2481f7a1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,7 @@
#
-# Maintainer: Clemens Buchacher <drizzd@aon.at>
-# Contributor: wangjiezhe <wangjiezhe AT yandex DOT com>
+# Maintainer: Carlos Aznarán <caznaranl@uni.pe>
+# Contributor: wangjiezhe <wangjiezhe@gmail.com>
+# Contributor: Clemens Buchacher <drizzd@aon.at>
#
# You can use the newpkg script from
# https://github.com/drizzd/octave-forge-archlinux to automatically generate
@@ -8,12 +9,12 @@
#
_pack=econometrics
-pkgname=octave-$_pack
+pkgname=octave-${_pack}
pkgver=1.1.2
pkgrel=1
-pkgdesc="Econometrics functions including MLE and GMM based techniques."
+pkgdesc="Econometrics functions including MLE and GMM based techniques"
arch=(any)
-url="https://octave.sourceforge.net/$_pack/"
+url="https://octave.sourceforge.io/${_pack}"
license=('GPL3')
groups=('octave-forge')
depends=('octave>=4.4.0' 'octave-optim')
@@ -21,39 +22,40 @@ makedepends=()
optdepends=()
backup=()
options=()
-install=$pkgname.install
-_archive=$_pack-$pkgver.tar.gz
-source=("https://downloads.sourceforge.net/octave/$_archive")
-noextract=("$_archive")
-sha256sums=('e2cca501f6b16ba4f2d5b4374dc3c80bd164472a30291dfd51947990263a3deb')
+install=${pkgname}.install
+_archive=${_pack}-${pkgver}.tar.gz
+source=("https://downloads.sourceforge.net/octave/${_archive}")
+noextract=("${_archive}")
+sha512sums=('7db08c5acb2b791f842642f158e9a5026358db09d0c427ba8da0c472a107b73c55b59e2458fc7623d5ebc874092e3a69e3d953228164da11a9a90b17079b47b9')
_octave_run() {
- octave --no-history --no-init-file --no-window-system -q -f --eval "$*"
+ octave --no-history --no-init-file --no-window-system -q -f --eval "$*"
}
_install_dir() {
- src=$1
- dst=$2
- mkdir -p "$(dirname "$dst")"
- cp -rT "$src" "$dst"
+ src=$1
+ dst=$2
+ mkdir -p "$(dirname "$dst")"
+ cp -rT "$src" "$dst"
}
build() {
- _prefix="$srcdir"/install_prefix
- _archprefix="$srcdir"/install_archprefix
- mkdir -p "$_prefix" "$_archprefix"
- cd "$srcdir"
- _octave_run "$(cat <<-EOF
+ _prefix="$srcdir"/install_prefix
+ _archprefix="$srcdir"/install_archprefix
+ mkdir -p "$_prefix" "$_archprefix"
+ cd "$srcdir"
+ _octave_run "$(
+ cat <<-EOF
pkg local_list octave_packages;
pkg prefix $_prefix $_archprefix;
pkg install -verbose -nodeps $_archive;
EOF
- )"
+ )"
}
package() {
- prefix=$pkgdir/usr/share/octave/packages
- archprefix=$pkgdir/usr/lib/octave/packages
- _install_dir "$srcdir"/install_prefix "$prefix"
- _install_dir "$srcdir"/install_archprefix "$archprefix"
+ prefix=$pkgdir/usr/share/octave/packages
+ archprefix=$pkgdir/usr/lib/octave/packages
+ _install_dir "$srcdir"/install_prefix "$prefix"
+ _install_dir "$srcdir"/install_archprefix "$archprefix"
}